bond + bridge not routing ipv6 correctly

Yesterday I migrated my home lab (6 vms, 2 esx servers), to proxmox using the clonezilla method. It all went well once I realized that I kept accidentally selecting the 16gb flashdrive proxmox is installed on as my vm's hard disk's datastore. Everything was working fine before, but my license key had expired a long time ago and I wanted live migration. my configuration is as follows:

eth0 wan interface -> vmbr0 -> pfsense wan
pfsense lan -> vmbr1 -> other vms and bond0 -> eth1,2,3 to switch

I started realizing after setting the network using the gui, that my ipv4 AND ipv6 traffic was really flaky, packets would drop, and in general things were really slow. I also noticed that in my syslog was the following, repeating itself thousands of times per minute
Code:
Nov  3 18:11:03 kamino kernel: bond0: received packet with own address as source address
I started searching around the forums here for people experiencing the same problem, and I found a couple threads which provided a solution to add a couple lines to your bridge config (indicated with ## below). I did that and it fixed my ipv4 problems immediately. All that traffic works great.

I then noticed that I was not getting dhcp6 leases, so I tried various ping scenarios, and tentatively determined that I cannot get ipv6 traffic through my bridge. This is my current config, does anyone have suggestions to get this to work?

Code:
# network interface settings
auto lo
iface lo inet loopback

iface eth0 inet manual

iface eth1 inet manual

iface eth2 inet manual

iface eth3 inet manual

auto bond0
iface bond0 inet manual
        slaves eth1 eth2 eth3
        bond_miimon 100
        bond_mode balance-xor

auto vmbr1
iface vmbr1 inet static
        address  10.1.1.8
        netmask  255.255.255.0
        gateway  10.1.1.1
        bridge_ports bond0
        bridge_stp on
        bridge_maxwait 0 ##
        bridge_maxage 0 ##
        bridge_fd 0
        bridge_ageing 0 ##

auto vmbr0
iface vmbr0 inet manual
        bridge_ports eth0
        bridge_stp off
        bridge_fd 0
 

fireon

Famous Member
Oct 25, 2010
3,702
286
103
39
Austria/Graz
iteas.at
I work on the same problem with Ubuntu. I don't know, but i think this feature use nobody. Every little network has an layer2 switch and with this you can use 802.3ad. With this i think it is not a problem... but... i've never tested this with IPV6/4 before. With IPV4 it works fine. Have a hand full servers running with 4nics+
 

athompso

Member
Sep 13, 2013
127
8
18
Short answer: don't use vmbr with balance-xor. Most of the other modes will work fine. LACP (aka 802.3ad) definitely does work correctly, but that requires configuration in your next-hop (hardware) switch. Active-passive will definitely work correctly. Balance-arp *should* but I've never tested it.
-Adam
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!