Backup Error -6 : No data available - Proxmox ve 5.4-3

RHC Hosting

Member
Jun 7, 2018
8
0
21
40
Dear All,
When trying to backup a VM, the following message occurs after 3%. on another vm, it occurs after 69%.
All vms are ok and clean.
All vms are booting ok
There is enough storage space on local disk
Tried a NFS Storage too, same error.
Tried backing up live and stopped, same error.
This is the full log :
------
NFO: starting new backup job: vzdump 125 --node tb-3 --storage bkps --compress lzo --remove 0 --mode snapshot
INFO: Starting Backup of VM 125 (qemu)
INFO: status = stopped
INFO: update VM 125: -lock backup
INFO: backup mode: stop
INFO: ionice priority: 7
INFO: VM Name: debas-1
INFO: include disk 'scsi0' 'nvstorage:vm-125-disk-0' 20G
INFO: creating archive '/var/lib/vz/dump/vzdump-qemu-125-2020_11_04-11_35_01.vma.lzo'
INFO: starting kvm to execute backup task
INFO: started backup task '884e879f-9f4d-41f6-a09f-7206b0787d62'
INFO: status: 1% (348192768/21474836480), sparse 0% (169164800), duration 1, read/write 348/179 MB/s
ERROR: job failed with err -61 - No data available
INFO: aborting backup job
INFO: stopping kvm after backup task
ERROR: Backup of VM 125 failed - job failed with err -61 - No data available
INFO: Backup job finished with errors
TASK ERROR: job errors
-----------

Any help will be greatly appreciated.

Thanks
 
Last edited:

oguz

Proxmox Staff Member
Staff member
Nov 19, 2018
5,009
632
118
hi,

can you post your vm configs qm config VMID for both failing VMs?

also please your /etc/pve/storage.cfg file
 
  • Like
Reactions: RHC Hosting

RHC Hosting

Member
Jun 7, 2018
8
0
21
40
Hello Oguz,

Thanks for your assistance. Please see below :

-------

root@tb-3:~# cat /etc/pve/storage.cfg
dir: local
path /var/lib/vz
content vztmpl,iso,backup
maxfiles 1
shared 0

lvmthin: local-lvm
thinpool data
vgname pve
content rootdir,images

lvm: nvstorage
vgname nvstorage
content images,rootdir
shared 0

nfs: bkps
export /bkps
path /mnt/pve/bkps
server 91.107.120.4
content backup
maxfiles 3
options vers=3
----------

root@tb-3:~# qm config 125
bootdisk: scsi0
cores: 2
description: 192.168.1.15
ide2: local:iso/CentOS-7-x86_64-Minimal-1810.iso,media=cdrom
memory: 2048
name: debas-1
net0: virtio=1A:48:FD:5F:A4:60,bridge=vmbr0,firewall=1
numa: 0
ostype: l26
scsi0: nvstorage:vm-125-disk-0,size=20G
scsihw: virtio-scsi-pci
smbios1: uuid=ef5b6796-da46-4429-86e0-3d01b7a7f3b8
sockets: 2
vmgenid: 972dd290-d7a7-4f57-88c4-1671dcbba56b


and

qm config 170
bootdisk: scsi0
cores: 2
description: 192.168.1.18
ide2: none,media=cdrom
memory: 2048
name: debas-2
net0: virtio=E2:F3:21:6B:3F:E2,bridge=vmbr0,firewall=1
numa: 0
ostype: l26
scsi0: nvstorage:vm-170-disk-0,size=15G
scsihw: virtio-scsi-pci
smbios1: uuid=1e044aa7-066c-402b-ac44-ebdb67948b1b
sockets: 2
vmgenid: d895a5d5-4417-4cac-9234-34157be5a006


-------

Thanks
 
Last edited:

oguz

Proxmox Staff Member
Staff member
Nov 19, 2018
5,009
632
118
have you tried making a local backup instead of on NFS drive? if the local backups work then it's likely an issue with your NFS or the connection to it.
 

RHC Hosting

Member
Jun 7, 2018
8
0
21
40
Yes, it failed on the local backup initially, reason why i tried an NFS. Also, i've updated Proxmox, didn't make any difference - rebooted the node, no change.

Any idea how this can be fixed?

Thanks again
 

oguz

Proxmox Staff Member
Staff member
Nov 19, 2018
5,009
632
118
okay.

maybe you can check the VM disks with fsck or similar?
 

RHC Hosting

Member
Jun 7, 2018
8
0
21
40
Hello Oguz, no errors on the disks...

What is puzzling is the error details : "ERROR: job failed with err -61 - No data available" - what does no data available mean? Although all the data is good - the vm starts ok, rw is ok - everything great, it's just the backup that doesn't run to completion. Is there another (easy) way to migrate vms to another node... ? I have 31 nodes to move, and they're all giving the same error. We have another node, same hardware specs, giving the EXACT same issue. So it's def. not the disk i would have thought... :-( :oops::confused:
 

RHC Hosting

Member
Jun 7, 2018
8
0
21
40
Anyone available to help? Still can't take backups :-(

Error is Backup of VM 125 failed - job failed with err -61 - No data available

Thanks in advance.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!