1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[SOLVED] apt-get update 403 Forbidden direct adsl no proxy

Discussion in 'Proxmox VE: Installation and configuration' started by regg, Jul 7, 2012.

  1. regg

    regg New Member

    Joined:
    Jul 7, 2012
    Messages:
    2
    Likes Received:
    0
    hello

    I am trying to do a apt-get update in the host machine returning me a 403 Forbidden. I checked this sources in a guest machine and this work perfectly.
    I use a direct adsl internet connection.

    ideas?

    Regards, Regg

    this is my source.list
    Code:
    /etc/apt# cat sources.list
    deb http://ftp.us.debian.org/debian/ squeeze main contrib
    #deb http://http.us.debian.org/debian squeeze main contrib
    
    
    # PVE packages provided by proxmox.com
    deb http://download.proxmox.com/debian squeeze pve
    
    
    # security updates
    deb http://security.debian.org/ squeeze/updates main contrib
    

    Code:
    /etc/apt# apt-get update
    Ign http://ftp.us.debian.org squeeze Release.gpg
    Ign http://ftp.us.debian.org/debian/ squeeze/contrib Translation-en
    Ign http://ftp.us.debian.org/debian/ squeeze/contrib Translation-en_US
    Ign http://ftp.us.debian.org/debian/ squeeze/main Translation-en
    Ign http://ftp.us.debian.org/debian/ squeeze/main Translation-en_US
    Ign http://ftp.us.debian.org squeeze Release
    Ign http://ftp.us.debian.org squeeze/main amd64 Packages/DiffIndex
    Ign http://ftp.us.debian.org squeeze/contrib amd64 Packages
    Ign http://ftp.us.debian.org squeeze/main amd64 Packages
    Err http://ftp.us.debian.org squeeze/contrib amd64 Packages
      403  Forbidden [IP: 64.50.236.52 80]
    Err http://ftp.us.debian.org squeeze/main amd64 Packages
      403  Forbidden [IP: 64.50.236.52 80]
    Ign http://download.proxmox.com squeeze Release.gpg
    Ign http://download.proxmox.com/debian/ squeeze/pve Translation-en
    Ign http://download.proxmox.com/debian/ squeeze/pve Translation-en_US
    Ign http://download.proxmox.com squeeze Release
    Ign http://download.proxmox.com squeeze/pve amd64 Packages
    Err http://download.proxmox.com squeeze/pve amd64 Packages
      403  Forbidden
    Ign http://security.debian.org squeeze/updates Release.gpg
    Ign http://security.debian.org/ squeeze/updates/contrib Translation-en
    Ign http://security.debian.org/ squeeze/updates/contrib Translation-en_US
    Ign http://security.debian.org/ squeeze/updates/main Translation-en
    Ign http://security.debian.org/ squeeze/updates/main Translation-en_US
    Ign http://security.debian.org squeeze/updates Release
    Ign http://security.debian.org squeeze/updates/main amd64 Packages
    Ign http://security.debian.org squeeze/updates/contrib amd64 Packages
    Err http://security.debian.org squeeze/updates/main amd64 Packages
      403  Forbidden
    Err http://security.debian.org squeeze/updates/contrib amd64 Packages
      403  Forbidden
    W: Failed to fetch http://ftp.us.debian.org/debian/dists/squeeze/contrib/binary-amd64/Packages.gz  403  Forbidden [IP: 64.50.236.52 80]
    
    
    W: Failed to fetch http://ftp.us.debian.org/debian/dists/squeeze/main/binary-amd64/Packages.gz  403  Forbidden [IP: 64.50.236.52 80]
    
    
    W: Failed to fetch http://download.proxmox.com/debian/dists/squeeze/pve/binary-amd64/Packages.gz  403  Forbidden
    
    
    W: Failed to fetch http://security.debian.org/dists/squeeze/updates/main/binary-amd64/Packages.gz  403  Forbidden
    
    
    W: Failed to fetch http://security.debian.org/dists/squeeze/updates/contrib/binary-amd64/Packages.gz  403  Forbidden
    
    
    E: Some index files failed to download, they have been ignored, or old ones used instead.
    
     
    #1 regg, Jul 7, 2012
    Last edited: Jul 11, 2012
  2. ytra

    ytra New Member

    Joined:
    Dec 6, 2012
    Messages:
    5
    Likes Received:
    0
    Hopefully someone is still actively reading this post as it is a bit old. ;)

    Today I encountered the same problem desscribed in regg his post. The weird thing is when I do a wget http://ftp.us.debian.org/debian/dists/squeeze/contrib/binary-amd64/Packages.gz on my Proxmox node it fails with a 403. On my laptop that same wget succeeds so the repo is active.
    When I do a wget ftp://ftp.vim.org/pub/vim/unix/vim-7.3.tar.bz2 on my proxmox node for testing the internet connection it succeeds to my surprise.

    It appears the Proxmox update is somehow blocked. Does anyone have the experience with this? And more important can some help me in solving this issue?

    Thanks in advance!
     

Share This Page