after upgrade to PVE 6.0 don't work AD auth with SSL

kaa

New Member
Aug 17, 2019
1
0
1
50
Hi All!

I had a test cluster PVE 5.4 with authentication thru Active Directory (Win 2008 R2) with SSL enabled, worked well.

After upgrade to PVE 6.0 any user got message "Login failed. Please try again" while trying to log on.

In log I see:
Aug 17 07:59:17 pve-test-00114983 pvedaemon[3008247]: authentication failure; rhost=10.1.1.46 user=kaa@ad.test.org msg=SSL connect attempt failed error:1425F102:SSL routines:ssl_choose_client_version:unsupported protocol

If I disable SSL in Authentication properties page for AD record, users logged successfully.

Please, help with this issue - clear text password on network (without SSL) is big security hole.
 

gradinaruvasile

Active Member
Oct 22, 2015
75
10
28
I observed the same thing, in the pvedaemon logs i see
Code:
authentication failure; rhost=host_ipaddr user=username@domain msg=Connection reset by peer
 

gradinaruvasile

Active Member
Oct 22, 2015
75
10
28
So i got the solution for this.
Openssl from Debian Buster has an enforced encryption of TLS 1.2.
Older Windows Server versions have some older implementations, although they do seem to use 1.2 in the end.
The solution is either
1. to change
Code:
/etc/ssl/openssl.cnf
and change
Code:
MinProtocol = TLSv1.2
to:
Code:
MinProtocol = TLSv1.0
then
Code:
systemctl restart pvedaemon

2. Install a newer Windows server for DC (on our newer Windows 2016 DCs the login worked, but not on the older 2012 R2s).
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!