[SOLVED] Adding a new node to a cluster fails

stsinc

Member
Apr 15, 2021
66
0
11
Hi,
I am getting very familiar with Proxmox VE, after having ditched a previous configuration and rebuilt a brand new, functional one.
My cluster has 3 machines and I just bought a new machine which I intended to add to the existing cluster.

So, I added the new one the usual way (the new machine was installed, updated, and empty) but there is definitely something fishy with clusters and nodes, when dealt with from the GUI.

Here is what happened:
  • the new machine (i75) appears in the cluster, among the other nodes:

    Screenshot-20210426-204159.png
  • When I click on the new machine in the list, its shell is accessible -- and I can also SSH it from Remmina: its network interface is definitely working
  • But when I click on the new machine in the list:
    • the network details are empty
    • the System displays a beachball, nothing gets displayed
    • the Summary behaves exactly the same: beachball, "Loading", and no display
  • Also:
    • I can clone a CT from another node to i75
    • BUT when I access the CT from the list, the beachball is turning again and its details are empty -- I cannot change the root disk, for example

      Screenshot-20210426-205552.png
    • And when I try to delete the CT I just added to i75, the operation ends with a connection error
I have already rebuilt a whole installation two days ago and do not intend to repeat.
Can you give me comprehensive and secure instructions so that:
  1. I can securely add the new node to the cluster
  2. I can use the cluster again normally.
Best,
Stephen
 
Last edited:
Did you tried to close a web browser and login to there again after adding a node? Today added a node to a cluster wia web GUI, all was fine. Forgot to turn on a nested virtualization at the new node, as it was set at other nodes and migrations to the new node have failed, but it's another question.
 
Last edited:
Thank you for your response.
Yes, I did, I even:
  • cleaned the browser cache
  • tried with another browser, with a previously cleaned cache
  • cross SSH-ed root@<IPAddress> all nodes in the cluster
 
I used firefox on Ubuntu today to add the node. There was no problems. May be your problem is related to a DNS name resolution. Try to add the cluster nodes to /etc/hosts at the existing nodes and the new node.
 
Eventually, I found the solution in the (excellent) book: Mastering Proxmox by Wasim Ahmed.
Execute on the malfunctioning node, via SSH:
service pvedaemon restart service pveproxy restart service pvestatd restart
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!