Added quad-port NIC, no more connectivity?


Mar 1, 2018
Hey guys,

I am currently using the motherboard built-in NIC (enp2s0) to on my Proxmox box and everything is working fine. However, the second I plug an additional NIC card (in my case, an HP quad-port 1gbps), I lose in/out connectivity over my built-in NIC.

Am I missing something? Is there something I need to change/configure before adding that additional card?

In case it matters, my goal is to PCI passthrough that quad-port NIC to a pfSense VM.

Thanks in advance!
usually plugging a new NIC in should not change the name of the build in one - that's what predictable interface names ought to be there for.
Sadly sometimes it does not work as expected...

Check the output of `dmesg`, `ip link show` and `lspci -nnk` for hints as to where the problem might be.

In case it matters, my goal is to PCI passthrough that quad-port NIC to a pfSense VM.
check the reference documentation for pci(e) passthrough :

hope this helps!
  • Like
Reactions: abortionparty
Thanks a lot. Turns out, somehow, my NIC name changed after plugging in the new one. I didn't even think this was possible so thanks for pointing me in the right direction.
Glad your issue is resolved! Please mark the Thread as 'SOLVED' so that others know what to expect. (at the top post 'Thread Tools' -> 'Edit Thread' -> select 'SOLVED' as prefix)



The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!