[SOLVED] __SPAMLEVEL__ macro not working

bzg

Member
Jan 4, 2020
10
1
8
41
Hi Team,

I made a new Action Option exactly similar like the default Modify Spam Level:

1616427030176.png

And modified the Modify Header rule:
1616427074131.png

But looks like this is not working because in the mail headers I see that the X-SPAM-INFO is empty all the time and in the X-SPAM-LEVEL I just see the string "__SPAMLEVEL__":
1616427168022.png

What am I missing?
bzg
 

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
7,691
1,258
169
Works here...

What am I missing?
do you have any rule in your rule-system which matches on a Spam What Object?
(without any what match for spam the mail does not get processed by SpamAssassin (and would not have the required information present)

(you can add a what object with spam level 0 to still get the action to apply to all mails)

I hope this helps!
 

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
7,691
1,258
169
Glad that worked :) - please edit the thread and mark it as SOLVED - this helps others with similar questions
Thanks!
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!