6 to 7: switch to bullseye repo forces server to delete many packages?

alexc

Active Member
Apr 13, 2015
123
4
38
I have handy server I can play with (but not to kill it). Its /etc/apt/sources.list looks this way:

Code:
deb http://ftp.debian.org/debian buster main non-free contrib
deb http://ftp.debian.org/debian buster-updates main non-free contrib
deb http://security.debian.org buster/updates main non-free contrib

deb http://download.proxmox.com/debian/pve buster pve-no-subscription

as I try to do 6 to 7 upgrade I did repo lines replacement trick, and got this file in such an updated way:

Code:
deb http://ftp.debian.org/debian bullseye main non-free contrib
deb http://ftp.debian.org/debian bullseye-updates main non-free contrib
deb http://security.debian.org bullseye-security main non-free contrib

deb http://download.proxmox.com/debian/pve bullseye pve-no-subscription

As I run aptitude update (yes, I got used to aptitude instead of apt) and then run aptitude dist-upgrade it says that there are:
Code:
817 packages upgraded, 134 newly installed, 62 to remove and 0 not upgraded.

and these 62 packages to remove seems to be the problem "with the reason":
Code:
The following packages have unmet dependencies:
 libldb2 : Breaks: libldb1 (< 2:2~) but 2:1.5.1+really1.4.6-3+deb10u1 is installed
 libc6-dev : Breaks: libgcc-8-dev (< 8.4.0-2~) but 8.3.0-6 is installed
 python2.7-minimal : Breaks: libpython-stdlib (< 2.7.18) but 2.7.16-1 is installed
                     Breaks: python (< 2.7.18) but 2.7.16-1 is installed
                     Breaks: python-minimal (< 2.7.18) but 2.7.16-1 is installed
 python2.7 : Breaks: libpython-stdlib (< 2.7.18) but 2.7.16-1 is installed
             Breaks: python (< 2.7.18) but 2.7.16-1 is installed
             Breaks: python-minimal (< 2.7.18) but 2.7.16-1 is installed
 python : Depends: python2 (= 2.7.16-1) but 2.7.18-2 is to be installed
 libpython-stdlib : Depends: libpython2-stdlib (= 2.7.16-1) but 2.7.18-2 is to be installed
 dh-python : Breaks: python but 2.7.16-1 is installed
 libpython2.7-minimal : Breaks: libpython-stdlib (< 2.7.18) but 2.7.16-1 is installed
                        Breaks: python (< 2.7.18) but 2.7.16-1 is installed
                        Breaks: python-minimal (< 2.7.18) but 2.7.16-1 is installed
 perl : Breaks: perl-modules-5.24 but 5.24.1-3+deb9u7 is installed
 python3-chardet : Breaks: python-chardet (< 3.0.4-6) but 3.0.4-3 is installed
 python-minimal : Depends: python2-minimal (= 2.7.16-1) but 2.7.18-2 is to be installed

So the question is, if I miss something and I really need to remove this big part of system (seems that no).

Version used is 6.4-18, like this:

Code:
# pveversion --verbose
proxmox-ve: 6.4-1 (running kernel: 5.4.124-1-pve)
pve-manager: 6.4-13 (running version: 6.4-13/9f411e79)
pve-kernel-5.4: 6.4-4
pve-kernel-helper: 6.4-4
pve-kernel-5.4.124-1-pve: 5.4.124-1
pve-kernel-5.4.119-1-pve: 5.4.119-1
ceph-fuse: 12.2.11+dfsg1-2.1+b1
corosync: 3.1.2-pve1
criu: 3.11-3
glusterfs-client: 5.5-3
ifupdown: residual config
ifupdown2: 3.0.0-1+pve4~bpo10
ksm-control-daemon: 1.3-1
libjs-extjs: 6.0.1-10
libknet1: 1.20-pve1
libproxmox-acme-perl: 1.1.0
libproxmox-backup-qemu0: 1.1.0-1
libpve-access-control: 6.4-3
libpve-apiclient-perl: 3.1-3
libpve-common-perl: 6.4-3
libpve-guest-common-perl: 3.1-5
libpve-http-server-perl: 3.2-3
libpve-storage-perl: 6.4-1
libqb0: 1.0.5-1
libspice-server1: 0.14.2-4~pve6+1
lvm2: 2.03.02-pve4
lxc-pve: 4.0.6-2
lxcfs: 4.0.6-pve1
novnc-pve: 1.1.0-1
proxmox-backup-client: 1.1.10-1
proxmox-mini-journalreader: 1.1-1
proxmox-widget-toolkit: 2.6-1
pve-cluster: 6.4-1
pve-container: 3.3-6
pve-docs: 6.4-2
pve-edk2-firmware: 2.20200531-1
pve-firewall: 4.1-4
pve-firmware: 3.2-4
pve-ha-manager: 3.1-1
pve-i18n: 2.3-1
pve-qemu-kvm: 5.2.0-6
pve-xtermjs: 4.7.0-3
pve-zsync: 2.2
qemu-server: 6.4-2
smartmontools: 7.2-pve2
spiceterm: 3.1-1
vncterm: 1.6-2
zfsutils-linux: 2.0.4-pve1

appears to be fresh versions...

How can I fix that and not to do simple reinstall?
 

leesteken

Famous Member
May 31, 2020
2,666
579
118
Proxmox VE 7 is officially released (no longer beta) but Debian 11 Bullseye not yet. I do see that Proxmox 7 usually does not use non-free, only main and contrib:
deb http://ftp.debian.org/debian bullseye main contrib deb http://ftp.debian.org/debian bullseye-updates main contrib deb http://security.debian.org bullseye-security main contrib
Maybe some installed software is cause dependency issues? I did not see any issues with python 2 and 3 (both could be installed at the same time) while installing a fresh 7 and also upgrading a 6.4 to 7. Did pve6to7 report any issue beforehand?
 

t.lamprecht

Proxmox Staff Member
Staff member
Jul 28, 2015
5,568
1,838
174
South Tyrol/Italy
shop.proxmox.com
As I run aptitude update (yes, I got used to aptitude instead of apt) and then run aptitude dist-upgrade it says that there are:
We do not support aptitude, it can work but it behaves differently and is NOT tested by us. apt is the official and recommended way to upgrade Proxmox VE.

Note, that in general some packages removal on major upgrades are fine, pythont2, for example is EOL and not supported anymore in Debian Bullseye: https://lists.debian.org/debian-python/2019/07/msg00080.html

So, most python2 packages will be replaced by new python3 compatible ones - that's fine and OK. Same with libraries that got an ABI bump, replaced by a newer one.
817 packages upgraded, 134 newly installed, 62 to remove and 0 not upgraded.
I mean, you get 62 removed, 134 new installed, those new will be mostly the replacement for the removed.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!