401 pmg ticket not read

tcsis

New Member
Oct 28, 2019
29
0
1
37
good morning doing a cluester on 2 VM I have the problem listed in the subject pmg error. There are particular ports to open between the two servers I have openot 8006 tcp and 22 tcp
 

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
5,908
808
148
* please post the logs from both PMG instances.
* where do you see the error?
* what's the output of pmgcm status
 

tcsis

New Member
Oct 28, 2019
29
0
1
37
while hi click on dashboard
status is :

root@rutigw:~# pmgcm status
no cluster defined

thanks
 

Attachments

  • Cattura1.PNG
    Cattura1.PNG
    55 KB · Views: 5
  • Cattura2.PNG
    Cattura2.PNG
    10 KB · Views: 5

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
5,908
808
148
did the cluster ever work? or did creating a cluster not work initially?
any information in the logs?

else you can try to recreate the cluster:
* make a backup of both machines
* recreate the cluster:
** remove /etc/pmg/cluster.conf on both nodes
** create the cluster again
** capture any problem you encounter while creating the cluster
 

tcsis

New Member
Oct 28, 2019
29
0
1
37
the problem with the creation phase is due to the moment in which all the machines have a firewall in front and they are on different clusters which ports I have to open for the cluster besides the 8006 and 22
 

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
5,908
808
148
ports 8006 and 22 should be enough - please post the logs
 

tcsis

New Member
Oct 28, 2019
29
0
1
37
sysolg cluster

Apr 7 12:17:41 mailgw pmgmirror[2991]: cluster syncronization finished (0 errors, 0.23 seconds (files 0.17, database 0.06, config 0.00))
Apr 7 12:19:23 mailgw postfix/smtpd[789]: connect from unusnovemseptem.xi.ecm-cluster.com[91.192.42.197]
Apr 7 12:19:30 mailgw postfix/smtpd[789]: 412D11D018AC: client=unusnovemseptem.xi.ecm-cluster.com[91.192.42.197]
Apr 7 12:19:35 mailgw postfix/smtpd[789]: disconnect from unusnovemseptem.xi.ecm-cluster.com[91.192.42.197] ehlo=1 mail=1 rcpt=1 data=1 quit=1 commands=5
Apr 7 12:19:40 mailgw pmgmirror[2991]: starting cluster syncronization
Apr 7 12:19:40 mailgw pmgmirror[2991]: cluster syncronization finished (0 errors, 0.27 seconds (files 0.16, database 0.11, config 0.00))
Apr 7 12:19:45 mailgw postfix/smtpd[889]: 73D671D01919: client=localhost[127.0.0.1], orig_client=unusnovemseptem.xi.ecm-cluster.com[91.192.42.197]
Apr 7 12:21:40 mailgw pmgmirror[2991]: starting cluster syncronization
Apr 7 12:21:40 mailgw pmgmirror[2991]: cluster syncronization finished (0 errors, 0.21 seconds (files 0.15, database 0.06, config 0.00))
 

tcsis

New Member
Oct 28, 2019
29
0
1
37
deamon log
root@mailgw:~# tail -f /var/log/daemon.log
Apr 7 13:39:40 mailgw pmgmirror[2991]: starting cluster syncronization
Apr 7 13:39:40 mailgw pmgmirror[2991]: cluster syncronization finished (0 errors, 0.23 seconds (files 0.16, database 0.08, config 0.00))
Apr 7 13:40:45 mailgw freshclam[527]: Received signal: wake up
Apr 7 13:40:45 mailgw freshclam[527]: ClamAV update process started at Tue Apr 7 13:40:45 2020
Apr 7 13:40:50 mailgw freshclam[527]: daily.cvd database is up to date (version: 25774, sigs: 2248800, f-level: 63, builder: raynman)
Apr 7 13:40:50 mailgw freshclam[527]: main.cvd database is up to date (version: 59, sigs: 4564902, f-level: 60, builder: sigmgr)
Apr 7 13:40:50 mailgw freshclam[527]: bytecode.cvd database is up to date (version: 331, sigs: 94, f-level: 63, builder: anvilleg)
Apr 7 13:40:50 mailgw freshclam[527]: safebrowsing.cvd database is up to date (version: 49191, sigs: 2213119, f-level: 63, builder: google)
Apr 7 13:41:40 mailgw pmgmirror[2991]: starting cluster syncronization
Apr 7 13:41:40 mailgw pmgmirror[2991]: cluster syncronization finished (0 errors, 0.23 seconds (files 0.16, database 0.07, config 0.00))
Apr 7 13:43:40 mailgw pmgmirror[2991]: starting cluster syncronization
Apr 7 13:43:40 mailgw pmgmirror[2991]: cluster syncronization finished (0 errors, 0.22 seconds (
 

tcsis

New Member
Oct 28, 2019
29
0
1
37
Making the installation I entered domain 8.8.8.8 and not tcsis.it every reboot I have to change it where I can change this setting permanently
 

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
5,908
808
148
it every reboot I have to change it where I can change this setting permanently
how do you change it on reboot? - sorry not sure where you entered 8.8.8.8?
 

tcsis

New Member
Oct 28, 2019
29
0
1
37
uring installation I entered 8.8.8.8 as hostdomain and not tcsis.it as it should be how do I write it in the configuration altirmenti every reboot I have to change it in postfix and in the hostdomain
 

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
5,908
808
148
please post:
* `cat /etc/resolv.conf`
* `cat /etc/hosts`
* `pmgconfig dump`
(replace only what you need to keep private)

Thanks
 

tcsis

New Member
Oct 28, 2019
29
0
1
37
search tcsis.it if reboot search in 8.8.8.8
nameserver 8.8.4.4
nameserver 8.8.8.8
# --- BEGIN PVE ---
# --- END PVE ---

cat /etc/hosts
127.0.0.1 localhost
::1 localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
# --- BEGIN PVE ---
10.70.70.6 mailgw.tcsis.it mailgw
# --- END PVE ---

root@mailgw:~# pmgconfig dump
could not change directory to "/root": Permission denied
composed.wl_bounce_relays = mailgw.tcsis.it
dns.domain = tcsis.it
dns.fqdn = mailgw.tcsis.it
dns.hostname = mailgw
ipconfig.int_ip = 10.70.70.6
pmg.admin.advfilter = 1
pmg.admin.avast = 0
pmg.admin.clamav = 1
pmg.admin.custom_check = 0
pmg.admin.custom_check_path = /usr/local/bin/pmg-custom-check
pmg.admin.dailyreport = 1
pmg.admin.demo = 0
pmg.admin.dkim_selector =
pmg.admin.dkim_sign = 0
pmg.admin.dkim_sign_all_mail = 0
pmg.admin.email = admin@domain.tld
pmg.admin.http_proxy =
pmg.admin.statlifetime = 7
pmg.clamav.archiveblockencrypted = 0
pmg.clamav.archivemaxfiles = 1000
pmg.clamav.archivemaxrec = 5
pmg.clamav.archivemaxsize = 25000000
pmg.clamav.dbmirror = database.clamav.net
pmg.clamav.maxcccount = 16
pmg.clamav.maxscansize = 100000000
pmg.clamav.safebrowsing = 1
pmg.mail.banner = ESMTP Proxmox
pmg.mail.before_queue_filtering = 0
pmg.mail.conn_count_limit = 3000
pmg.mail.conn_rate_limit = 0
pmg.mail.dnsbl_sites = b.barracudacentral.org,zen.spamhaus.org,psbl.surriel.com,bl.spamcop.net,mail-abuse.org,virus.rbl.jp,zombie.dnsbl.sorbs.net,ix.dnsbl.manitu.net
pmg.mail.dnsbl_threshold = 1
pmg.mail.dwarning = 4
pmg.mail.ext_port = 25
pmg.mail.greylist = 1
pmg.mail.helotests = 1
pmg.mail.hide_received = 0
pmg.mail.int_port = 26
pmg.mail.max_filters = 38
pmg.mail.max_policy = 5
pmg.mail.max_smtpd_in = 100
pmg.mail.max_smtpd_out = 100
pmg.mail.maxsize = 10485760
pmg.mail.message_rate_limit = 0
pmg.mail.ndr_on_block = 0
pmg.mail.rejectunknown = 1
pmg.mail.rejectunknownsender = 1
pmg.mail.relay = yes
pmg.mail.relaynomx = 0
pmg.mail.relayport = 25
pmg.mail.relayprotocol = smtp
pmg.mail.smarthost =
pmg.mail.smarthostport = 25
pmg.mail.spf = 1
pmg.mail.tls = 0
pmg.mail.tlsheader = 0
pmg.mail.tlslog = 0
pmg.mail.verifyreceivers =
pmg.spam.bounce_score = 0
pmg.spam.clamav_heuristic_score = 3
pmg.spam.languages = en ga ar de es it la fr hy
pmg.spam.maxspamsize = 262144
pmg.spam.rbl_checks = 1
pmg.spam.use_awl = 1
pmg.spam.use_bayes = 1
pmg.spam.use_razor = 1
pmg.spam.wl_bounce_relays =
pmg.spamquar.allowhrefs = 1
pmg.spamquar.authmode = ticket
pmg.spamquar.hostname =
pmg.spamquar.lifetime = 30
pmg.spamquar.mailfrom =
pmg.spamquar.port = 8006
pmg.spamquar.protocol = https
pmg.spamquar.reportstyle = verbose
pmg.spamquar.viewimages = 1
pmg.virusquar.allowhrefs = 1
pmg.virusquar.lifetime = 15
pmg.virusquar.viewimages = 1
postfix.dnsbl_sites = b.barracudacentral.org,zen.spamhaus.org,psbl.surriel.com,bl.spamcop.net,mail-abuse.org,virus.rbl.jp,zombie.dnsbl.sorbs.net,ix.dnsbl.manitu.net
postfix.dnsbl_threshold = 1
postfix.int_ip = 10.70.70.6
postfix.mynetworks = 127.0.0.0/8 [::1]/128 10.70.70.0/24
postfix.transportnets =
postfix.usepolicy = 1
postgres.version = 11
 

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
5,908
808
148
It seems this is running as a container on PVE?
if yes - then change the DNS domain in the container config
 

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
5,908
808
148
Apr 7 13:39:40 mailgw pmgmirror[2991]: cluster syncronization finished (0 errors, 0.23 seconds (files 0.16, database 0.08, config 0.00))
seems your cluster is working - is the time on both nodes synchronized?
 

tcsis

New Member
Oct 28, 2019
29
0
1
37
root@mailgw:~# date
Thu 09 Apr 2020 03:40:22 PM CEST

root@mailgw2:~# date
Thu 09 Apr 2020 03:40:51 PM CEST
 

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
5,908
808
148
please post the output of `pmgcm status` from both nodes and the journal for pmgmirror for both nodes (`journalctl -u pmgmirror`)
and verify that /etc/pmg/cluster.conf is the same on both nodes (keep in mind that it contains sensitive information)
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!