Search results

  1. Unable to mount thin-provisioned LVM volume?

    Hi, I have six Proxmox hypervisors (various licenses) running 5.4 which I began upgrading this week (to 6.2-4). I'm on the second machine today and running into the same problem that I had on my first upgrade. There is an LVM volume defined from the 5.4 Proxmox install which is tagged with...
  2. pmxcfs segfault at reboot after proxmox 6.x upgrade

    I've upgraded a remote proxmox host from 5.4 to 6.x using the instructions here and ran into a problem after issuing a reboot at the (remote KVM Blackbox) console. It looks like pmxcfs crashed during reboot. The machine has been sitting here for nearly 30 minutes. Any way to unstick it?
  3. systemd can't start sshd after 5.x -> 6.x upgrade

    Hi, Anyone know how to fix this? I can start sshd by hand using /usr/sbin/sshd -DDD and no errors are present. At boot however, systemd is having problems and I can't login. journalctl -xb says this: pam_systemd(sshd:session): Failed to connect to system bus: No such file or directory
  4. When does 'nextduedate' change when running pvesubscription

    I have a Nagios handler which notifies me when a host's Proxmox subscription has 30 days, or less, left on it's license (so renewals don't sneak up on us). It's 2020-02-04 and the nextdudate field hasn't changed on my proxmox hosts. The license is active, so I presume it's been "auto renewed"...
  5. Why do some of my Proxmox hosts occasionally fail to reboot?

    I first noticed this issue with Proxmox 5.4 and suspect it has everything to do with Systemd integration, and very little with Proxmox itself, but it bites me in the backside every so often so would like to bring it up and see if there's something I should be doing differently or a fix for it...
  6. libssl1.0.2 update trying to rebuild initrd and failing

    Hi, I've tried applying the latest libssl1.0.2 update on several of my Proxmox 5.4 hosts and this is failing with "/usr/sbin/grub-mkconfig: 7: /etc/default/grub: GRUB: not found" Any thoughts? Sample output is below. Reading package lists... Done Building dependency tree Reading state...
  7. Any way to restore the "old" UI for the VNC console?

    The little fly-out tab on the left (in the VNC console) obscures content when in a shell session. I've also found it a bit cumbersome to work with and doesn't really add any utility to the vnc session over the old UI using the toolbar at the top of the screen that I can tell. Making it modal...
  8. "noVNC encountered an error" after updating

    Applied the recent round of patches last night and rebooted them. This morning when I try to get into a VM through the VNC console, I get "noVNC encountered and error" and the display never comes up. I'm using Firefox over an ssh tunnel to connect. Have tried CTRL+F5 as suggested to clear...
  9. Weird kernel dumps ?

    Since upgrading to 5.2, I've been getting VM crashes intermittently. They don't seem to be related to any one hypervisor and I can't actually tell what's wrong from the console message (below). Anyone have any ideas where to look for the problem? Seems like we used to get these years ago when...
  10. 401 Unauthorized but key is valid?

    Hello, Anyone know where to look for this problem? It was happening on two hosts I recently upgraded to 5.2. Today it seems only one. 3rd party subscription vendor says it might be permissions on /etc/pve but I am running the update as root from the shell and have read access to everything under...
  11. Proxmox 5.2 boot hangs at "Loading initial ramdisk"

    I've installed Proxmox 5.2 on a Supermico X10DRI-LN4 board and Xeon 2637 v3 CPUS. Areca raid controller with a sata array as the boot volume. Have installed twice. After the grub menu disappears, I get: Loading Linux 4.15.17-1-pve... Loading initial ramdisk... But no boot actually happens...
  12. Best way to manage "Invalid Server ID" after reinstall?

    Hello, Is there some tip for reinstalling Proxmox that will not mess up the status of the Subscription Key? I've been waiting (so far) 12 hours for the "Invalid Server ID" status to clear (two support tickets with a third party license provider) so I can begin provisioning the server. Is there...
  13. 4.4 to 5.2 upgrade. Why is pve-data corrupt?

    I upgraded from 4.4 to 5.2 recently and noticed my /var/lib/vz ext4 filesystem didn't survive the upgrade. Is this a known issue with Debian 9 or something? On 4.4 this system was rebooted, and fsck'd, practically every weekend for either Proxmox or SAN upgrades so I'm wondering if the error is...
  14. What do I need to do to disable IPv6?

    I'll never use IPv6 and want to disable it completely. I don't like having rpcbind or ssh running on both v4 and v6. I've tried disabling using sysctl but getting errors in the logs from pve-firewall: iptables_restore_cmdlist: Try `ip6tables-restore -h' or 'ip6tables-restore --help' for...
  15. Why is /dev full on my LXC container?

    New to containers, so maybe overlooking something - why is /dev at 100% on my container? After a reboot it was fine. 5 days uptime: $ df -mh Filesystem Size Used Avail Use% Mounted on /dev/mapper/pve-vm--700--disk--1 50G 25G 22G 54% / none...
  16. cannot connecto to (https) enterprise.proxmox.com/

    pveupdate fails to run command 'apt-get update' failed: exit code 100 running aptitude update produces an error connecting to https://enterprise.proxmox.com/ Is this a known issue? Thank you # aptitude update Hit http://security.debian.org jessie/updates InRelease Ign http://ftp.us.debian.org...
  17. How can I expose a NIC to a container?

    I have an IDS system I've containerized. eth0 is on vmbr0 while eth3 is an interface running from a SPAN session of a Cisco switch. I've tried creating a new bridge (vmbr100) and added eth3 to it. This allows the container to see UDP traffic from the SPAN session but none of the TCP traffic...
  18. How to convert bare metal FS to LXC Container?

    I'm just trying out containers in Proxmox 4.4. I have a 1U bare metal I'd like to convert to a container. I've done this with KVM by booting the VM with a cdrom and then using rsync to copy files over from a hard disk/usb stick onto the VM filesystem. I don't see a cdrom boot option for LXC...
  19. I created a new bridge but it's not up after boot

    I created a bridge (vmbr3) yesterday and rebooted my proxmox hypervisor but vmbr3 is not coming up at boot and the VM using this bridge is failing to start automatically. I can `ifup vmbr3` and start the VM by hand, but I'd like to know what's not working correctly. My /etc/network/interfaces...
  20. Running a VM from a Glusterfs filesystem

    I have a Glusterfs system running over Infiniband which I'm testing with Proxmox 3.4 (soon to be upgraded to 4.4). The vzdumps work great but I'm wondering how I can run my VM images directly from the Glusterfs mount point without a huge performance degradation. I tried SATA disks with obvious...

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!