Search results

  1. [SOLVED] Proxmox 6.0 Gemini Lake and IGD (graphics) passthrough for Windows 10

    Bestbeast, vBIOS is contained in the UEFI of your motherboard. Mainboard: Asus Z97K VID\PID of the videocard: 8086:0412 Instructions: mainly under Windows. 01. Download the MMTool v5.02.0024. 02. Download the latest UEFI for Asus Z97K mainboard. 03. Extract the Z97-K-ASUS-2902.CAP file from...
  2. [SOLVED] Proxmox 6.0 Gemini Lake and IGD (graphics) passthrough for Windows 10

    Bestbeast, can you connect a monitor using a VGA (D-Sub) cable instead of HDMI? Maybe the video signal for some reason is not output via an HDMI cable.
  3. [SOLVED] Proxmox 6.0 Gemini Lake and IGD (graphics) passthrough for Windows 10

    1. Remove the line from the /etc/modprobe.d/blacklist.conf file: blacklist lpc_ich 2. Try modifying the line in the /etc/pve/qemu-server/<VMID>.conf file: args: -device vfio-pci-igd-lpc-bridge,id=vfio-pci-igd-lpc-bridge0,bus=pci.0,addr=1f.0 -device...
  4. [SOLVED] Proxmox 6.0 Gemini Lake and IGD (graphics) passthrough for Windows 10

    Bestbeast, add the line to the /etc/modprobe.d/blacklist.conf file: blacklist lpc_ich
  5. [SOLVED] Proxmox 6.0 Gemini Lake and IGD (graphics) passthrough for Windows 10

    What kind of device do you have? /sys/kernel/iommu_groups/13/devices/0000:00:1f.0 Perhaps the device can be turned off? For example, using /etc/modprobe.d/blacklist.conf.
  6. [SOLVED] Proxmox 6.0 Gemini Lake and IGD (graphics) passthrough for Windows 10

    Hello. Yes, edit the file /etc/modprobe.d/vfio.conf: options vfio-pci ids=8086:0412,8086:0c0c,8086:8ca0 disable_vga=1 Although about 8086:8ca0 is not sure.
  7. [SOLVED] Proxmox 6.0 Gemini Lake and IGD (graphics) passthrough for Windows 10

    Try adding the line to your VM configuration file: machine: q35 Try changing the line args: -device vfio-pci,host=00:02.0,addr=0x02,x-igd-gms=1,x-igd-opregion=on,romfile=vbios_hd4600.rom Try changing the line in the file /etc/default/grub: GRUB_CMDLINE_LINUX_DEFAULT="quiet intel_iommu=on...
  8. [SOLVED] Proxmox 6.0 Gemini Lake and IGD (graphics) passthrough for Windows 10

    Bestbeast, please make sure the following lines are in the file /etc/pve/qemu-server/<VMID>.conf: args: -device vfio-pci,host=00:02.0,addr=0x02,romfile=vBIOS_HD4600.rom bios: seabios vga: none Note: with OVMF (UEFI), this vBIOS ROM does not work!
  9. [SOLVED] Proxmox 6.0 Gemini Lake and IGD (graphics) passthrough for Windows 10

    Bestbeast, try this vBIOS (attached to the post). Unpack the vBIOS_HD4600.rom file from the archive into the /usr/share/kvm directory.
  10. [SOLVED] Proxmox 6.0 Gemini Lake and IGD (graphics) passthrough for Windows 10

    Bestbeast, 1. Please write your mainboard model. 2. Please write the result of the command: lspci -nn | grep "VGA"
  11. [SOLVED] Proxmox 6.0 Gemini Lake and IGD (graphics) passthrough for Windows 10

    Hello. I finally got an image on the screen when starting the virtual machine. For IGD passthrough, VBIOS is required. Extract the j5005_vbios.rom file from the archive in the attachment and copy it /usr/share/kvm. In the file /etc/pve/qemu-server/100.conf, write the following: args: -device...
  12. [SOLVED] Proxmox 6.0 Gemini Lake and IGD (graphics) passthrough for Windows 10

    I deleted the line: args: -device vfio-pci, host = 00: 02.0, addr = 0x18, x-igd-opregion = on And instead she wrote: hostpci0: 00:02 The VM configuration is as below: agent: 1 balloon: 0 bios: ovmf boot: dc bootdisk: sata0 cores: 2 cpu: host efidisk0: local:100/vm-100-disk-1.qcow2,size=128K...
  13. [SOLVED] Proxmox 6.0 Gemini Lake and IGD (graphics) passthrough for Windows 10

    # dmesg | grep -aiE '((DMAR)|(kvm)|(drm)|(Command line)|(iommu)|(vfio))' [ 0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-5.0.21-5-pve root=/dev/mapper/pve-root ro quiet intel_iommu=on iommu=pt rd.driver.pre=vfio-pci video=vesafb:off,efifb:off [ 0.012787] ACPI: DMAR 0x000000005D6A0D70...
  14. [SOLVED] Proxmox 6.0 Gemini Lake and IGD (graphics) passthrough for Windows 10

    Hello. I am a junior in virtualization. I'm trying passthrough an integrated video card inside a VM, but, unfortunately, when I start the VM, I see only blank screen (connection via HDMI). My PC configuration: - Mainboard: ASRock J5005-ITX; - CPU: Intel Pentium J5005; - RAM: 2 x 8Gb DDR4-2400...

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!