Search results

  1. [SOLVED] Proxmox VE 6.0: Ceph Nautilus Extraneous Monitors?

    I removed these old directories and my problem has been solved. Thank you!
  2. [SOLVED] Proxmox VE 6.0: Ceph Nautilus Extraneous Monitors?

    mihanson@pve01:~$ ls -lah /etc/systemd/system/ceph-mon.target.wants/ total 0 lrwxrwxrwx 1 root root 37 May 3 19:26 ceph-mon@a.service -> /lib/systemd/system/ceph-mon@.service mihanson@pve01:~$ sudo ls -lah /var/lib/ceph/mon/ [sudo] password for mihanson: total 16K drwxr-xr-x 4 ceph ceph 4.0K...
  3. [SOLVED] Proxmox VE 6.0: Ceph Nautilus Extraneous Monitors?

    I just double checked all 3 nodes and I only have the correct systemd services enabled for the monitors (ceph-mon@a.service on pve01; ceph-mon@b.service on pve02; ceph-mon@c.service on pve03). Any other ideas as to where else the extra monitors could be sourced from? I'm only seeing them on the...
  4. [SOLVED] Proxmox VE 6.0: New Ceph OSD, but GPT = No

    I'm starting to decode what I think may be the answer to my question. According to ceph-disk docs, ceph-disk, which was used for OSD creation is depreciated in favor of ceph-volume, which Proxmox uses to create LVM's out of raw devices. There are definite gaps in my knowledge here, but after...
  5. [SOLVED] Proxmox VE 6.0: Ceph Nautilus Extraneous Monitors?

    Just upgraded a 3 node cluster to PVE 6.0 last night. I followed the excellent upgrade docs for PVE and Ceph Nautilus upgrades. Before the upgrade from 5.4 I had three ceph monitors called 'a', 'b', 'c'. Mon-a is on host pve01; Mon-b is on host pve02; Mon-c is on host pve03. After the upgrade...
  6. [SOLVED] Proxmox VE 6.0: New Ceph OSD, but GPT = No

    Just upgraded a 3 node cluster to PVE 6.0 last night. I followed the excellent upgrade docs for PVE and Ceph Nautilus upgrades. I added a new OSD using a new hard drive. I initialized the Disk with GPT and the the disk appeared to have a GPT partition table per the "Disks" menu of the web GUI...
  7. Changing the ceph public network

    Did you enable and start the new monitors via systemd? # systemctl stop ceph-mon@<old-mon-id> # systemctl disable ceph-mon@<old-mon-id> # systemctl restart ceph-mon@<new-mon-id> # systemctl enable ceph-mon@<new-mon-id> You'd need to do this on each machine that hosts a monitor. Also note that...
  8. Changing the ceph public network

    Have you tried to simply restart the Ceph Manager? # systemctl restart ceph-mgr@prox01a I am in a similar situation where I started with Ceph using the same network for public and cluster. Now, I want to change the public network, but I'm not completely clear how to get that accomplished. The...
  9. [SOLVED] qm: Unrecognized Command: 'list_extent'

    Marking this "solved." The list extent error was solved by the author of the patches. The uninitialized value $type in string eq at /usr/share/perl5/PVE/QemuServer.pm line 2026 now has a bug report filed. Thanks.
  10. [SOLVED] Crossing Subnets with 10G Speeds (Bypassing Router)

    I worked around my issue by giving Proxmox (pve) an IPv4 address in the same subnet as my FreeNAS machine. Here is my working /etc/network/interfaces: auto lo iface lo inet loopback iface enp3s0 inet manual #Realtek RTL8111GR iface enp1s0 inet manual #Mellanox ConnectX-3 iface enp1s0.10 inet...
  11. [SOLVED] qm: Unrecognized Command: 'list_extent'

    Today I created two new Linux VM's on my FreeNAS storage. One is EFI based and the other is BIOS based. The good news is that the VM's boot and seems to be working as expected. However, when starting the VM's from the command line, I can see the following "list_extent" ZFS error...
  12. [SOLVED] qm: Unrecognized Command: 'list_extent'

    I recently patched my Proxmox 5.3 with the FreeNAS iSCSI API. I can now use the FreeNAS as storage. However, when I try to clone an existing EFI Linux VM onto the FreeNAS storage, I am seeing a ZFS error (unrecognized command 'list_extent'): As you can see, the command completes and the zvol's...
  13. What open source solutions are available to use "ZFS over iSCSI with Proxmox"?

    Thank you @raku for clarifing that for me. So starting fresh with this, here's what I've learned for anyone who may need to know. I hope it can be helpful: 1.) Get the FreeNAS patches and apply them per the instructions in the README.md. 2.) On FreeNAS 11.1, insure that your GUI is listening on...
  14. What open source solutions are available to use "ZFS over iSCSI with Proxmox"?

    Hi raku. Thanks for your response. Here's what I get in syslog when creating a new VM on the freenas-storage: Dec 11 09:22:02 pve systemd[1]: Started Proxmox VE replication runner. Dec 11 09:22:08 pve pvedaemon[2185]: <root@pam> starting task...
  15. What open source solutions are available to use "ZFS over iSCSI with Proxmox"?

    I'm having trouble utilizing any storage on my FreeNAS 11.1 box. I am unable to create or migrate/move any VM to the new ZFS-over-iSCSI disk I created. This is what I have done: Setup a 250 GiB zvol in the FreeNAS GUI Got the Proxmox-FreeNAS SSH key setup Setup the ZFS-over-iSCSI in the Proxmox...
  16. [SOLVED] Crossing Subnets with 10G Speeds (Bypassing Router)

    I use VLANs to isolate networks. i.e. I don't want my IoT devices to communicate with other computers on my network; I don't want my kid's computers to be able to get to mine; I don't want "guest" devices to be able to browse my network; I want to keep traffic from my multimedia computers or...
  17. [SOLVED] Crossing Subnets with 10G Speeds (Bypassing Router)

    Thank you for this. I'm trying to figure out how I accomplish using my Proxmox host (pve) to route itself and guests directly to FreeNAS without the USG sitting in the middle. Looking at the networking wiki page, do I just use the "Routed Configuration?" As I said, I'm not a networking guru and...
  18. [SOLVED] Crossing Subnets with 10G Speeds (Bypassing Router)

    Thank you for the reply. If I change the netmask to /16 (255.255.0.0) I lose connectivity to pve (if I change it there) or any of the guests (if I change it on them).
  19. [SOLVED] Crossing Subnets with 10G Speeds (Bypassing Router)

    Hi! I’m trying to take advantage of a 10G Mellanox ConnectX-3 EN (running the most recent firmware version, 2.42.5000) installed in my Proxmox (5.2) to utilize the full 10G bandwidth between Proxmox and a seperate FreeNAS (11.1) box and I’m running into trouble. My Proxmox host (pve) is on an...

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!