Results 1 to 6 of 6

Thread: Hang on reboot when stopping vz service

  1. #1
    Join Date
    Nov 2010
    Location
    Columbus, Ohio
    Posts
    967

    Default Hang on reboot when stopping vz service

    I have two nodes with identical hardware running the latest Proxmox 2.1 fully updated
    These are two brand new nodes, installed proxmox and joined them to existing cluster, they have no KVM or OpenVZ containers running on them.

    When rebooting one of them it hangs when stopping the vz service.
    The specific thing hanging is "modprobe -r vzrst"

    EDIT: This does not seem to fix it, the problem happens randomly and this does not help at all:
    When it hangs if I issue the command "/etc/init.d/open-iscsi stop" or if I do that before I try to reboot it does not hang.
    I am not using any iscsi devices.


    EDIT: It only seems to hang to 2-3 minutes when it hangs. It also seems to only hang every other reboot.

    The other machine, with identical hardware installed from the same media is not having this problem.

    Any idea what is wrong?
    Last edited by e100; 05-02-2012 at 08:51 PM. Reason: Additional info

  2. #2
    Join Date
    Apr 2013
    Posts
    13

    Default Re: Hang on reboot when stopping vz service

    Apologies for digging up an old thread but I notice this was never answered/resolved. I now find I am having the same problem.

    My config:
    - Proxmox VE 3.0 with all updates from the stable repository (no pvetest).
    - ZFS
    - Samba
    - Added drivers for a Mellanox ConnectX-EN 10Gbe card

    All VMs are KVM. I don't even need OpenVZ at all. No containers used. VMs & ISOs are local disk on a ZFS pool.

    On shutdown it gets to "Shutting down OpenVZ: " and then hangs forever on the "modprobe -r vzrst".

    Would really like to get this resolved so that shutdowns could be clean.

  3. #3
    Join Date
    Apr 2012
    Location
    Copenhagen, Denmark
    Posts
    1,763

    Default Re: Hang on reboot when stopping vz service

    Is the module loaded at all?

    On a running node do:
    lsmod | grep vzrst

  4. #4
    Join Date
    Apr 2013
    Posts
    13

    Default Re: Hang on reboot when stopping vz service

    I'll check this evening. But normally, "modprobe -r <unloaded module>" simply returns immediately rather than hanging.

    Also - this is for shutdown on a system that doesn't even use OpenVZ. Do I risk anything by just commenting out the "modprobe -r" from the /etc/init.d/vz script? It can't do any harm not to remove a module from a system that is just about to power off - and the chance that I'd ever do a "vz stop" or "vz restart" is pretty much zero.

    Even if I just comment out the modprobe I'd really like to understand why it hangs...

  5. #5
    Join Date
    Apr 2012
    Location
    Copenhagen, Denmark
    Posts
    1,763

    Default Re: Hang on reboot when stopping vz service

    If you are certain of that you will never need the driver you could blacklist it.

    create a file in /etc/modprobe.d/ named blacklist-vzrst.conf containing: blacklist vzrst

    Should prevent it from being autoloaded.

  6. #6
    Join Date
    Nov 2010
    Location
    Columbus, Ohio
    Posts
    967

    Default Re: Hang on reboot when stopping vz service

    I still see this problem all the time, it would be nice to see it fixed.

    I have a mix of openvz and kvm running but it does not seem to matter.
    Sometimes, but not always, the modprobe -r vzrst will use 100% cpu for some time, then finally exit.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •