Results 1 to 8 of 8

Thread: KVM_Cant start to used VNC Console

  1. #1
    Join Date
    Apr 2012
    Location
    Davao City, Philippines
    Posts
    1

    Default KVM_Cant start to used VNC Console

    Hi guys i install KVM VM on my proxmox version 2.0.57/ff6cd700

    And im having issue regarding USING VNC CONSOLE for KVM coz error apears and it wont start:

    Error:command'/bin/nc/-I -p 5900 -w 10 0c'/usr/sbin/qm vnproxy 103>/dev/null" failed: exit code 1

    Any idea guys..?

    while the openVZ vnc console are working perfect so far...Please help

  2. #2
    Join Date
    Apr 2005
    Location
    Austria
    Posts
    11,879

    Default Re: KVM_Cant start to used VNC Console

    Quote Originally Posted by rubenjr23 View Post
    Error:command'/bin/nc/-I -p 5900 -w 10 0c'/usr/sbin/qm vnproxy 103>/dev/null" failed: exit code 1
    That command looks strange - we do not issue such command! Should be '/bin/nc -l -p 5900 -w 10 -c ...'

  3. #3
    Join Date
    May 2011
    Location
    Chicago, United States
    Posts
    34

    Default Re: KVM_Cant start to used VNC Console

    I have the same problem after upgrading from 2.0 to 2.1

    no connection : Connection timed out
    TASK ERROR: command '/bin/nc -l -p 5900 -w 10 -c '/usr/sbin/qm vncproxy 107 2>/dev/null'' failed: exit code 1

    I get this for VM's on the master and on a node.

  4. #4
    Join Date
    May 2011
    Location
    Chicago, United States
    Posts
    34

    Default Re: KVM_Cant start to used VNC Console

    I restarted the host, then the node, now it is working again.

  5. #5
    Join Date
    May 2012
    Posts
    2

    Default Re: KVM_Cant start to used VNC Console

    Quote Originally Posted by ymmot04 View Post
    I restarted the host, then the node, now it is working again.
    Hi, i've the same promblem, I've restarted host and node but I've this error too

    What can I do?

  6. #6
    Join Date
    May 2011
    Location
    Chicago, United States
    Posts
    34

    Default Re: KVM_Cant start to used VNC Console

    Are both fully up to date? If not, run your updates then restart both again. If they are both up to date, just try another restart on both. I may have rebooted a couple times before it started working again.

  7. #7
    Join Date
    May 2012
    Posts
    2

    Default Re: KVM_Cant start to used VNC Console

    Quote Originally Posted by ymmot04 View Post
    Are both fully up to date? If not, run your updates then restart both again. If they are both up to date, just try another restart on both. I may have rebooted a couple times before it started working again.
    Host is updated. I've rebooted few times, but there is the same error

  8. #8
    Join Date
    Jan 2012
    Posts
    31

    Default Re: KVM_Cant start to used VNC Console

    hi,

    i have the same problem. when i open console for vm
    he starts nc .... but i get the following error:

    command '/bin/nc -l -p 5900 -w 10 -c '/usr/sbin/qm vncproxy 100 2>/dev/null'' failed: exit code 1


    if i run this command directly on commandline and try to connect with telnet localhost 5900 everything is fine.

    system is debian squeeze 6.0 fresh actual install.
    proxmox is also latest install packages:
    pve-manager: 2.1-14 (pve-manager/2.1/f32f3f46)
    running kernel: 2.6.32-14-pve
    proxmox-ve-2.6.32: 2.1-74
    pve-kernel-2.6.32-11-pve: 2.6.32-66
    pve-kernel-2.6.32-14-pve: 2.6.32-74
    lvm2: 2.02.95-1pve2
    clvm: 2.02.95-1pve2
    corosync-pve: 1.4.3-1
    openais-pve: 1.1.4-2
    libqb: 0.10.1-2
    redhat-cluster-pve: 3.1.92-3
    resource-agents-pve: 3.9.2-3
    fence-agents-pve: 3.1.8-1
    pve-cluster: 1.0-27
    qemu-server: 2.0-49
    pve-firmware: 1.0-18
    libpve-common-perl: 1.0-30
    libpve-access-control: 1.0-24
    libpve-storage-perl: 2.0-31
    vncterm: 1.0-3
    vzctl: 3.0.30-2pve5
    vzprocps: 2.0.11-2
    vzquota: 3.0.12-3
    pve-qemu-kvm: 1.1-8
    ksm-control-daemon: 1.1-1


    hope someone can verify the problem.

    thx
    patrick

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •