Results 1 to 6 of 6

Thread: Problems in upgrade from 1.3 to 1.5

  1. #1
    Join Date
    Dec 2009
    Posts
    16

    Default Problems in upgrade from 1.3 to 1.5

    At the outset, let me apologies for this very long post. But, I thought of adding all the available information.

    We are upgrading the Proxmox Virtual Environment on our servers from 1.3 to 1.5. We followed the steps on:
    http://pve.proxmox.com/wiki/Download...ent_1.x_to_1.5

    However, that doesn't work. The output is pasted below


    ***** The pveversion output before starting upgrade *****
    proxmox2:~# pveversion --verbose
    pve-manager: 1.3-1 (pve-manager/1.3/4023)
    qemu-server: 1.0-14
    pve-kernel: 2.6.24-8
    pve-kvm: 86-1
    pve-firmware: 1
    vncterm: 0.9-2
    vzctl: 3.0.23-1pve3
    vzdump: 1.1-2
    vzprocps: 2.0.11-1dso2
    vzquota: 3.0.11-1
    proxmox2:~#

    ***** Starting to upgrade after 'apt-get update' *****
    proxmox2:~# apt-get upgrade
    Reading package lists... Done
    Building dependency tree... Done
    The following packages have been kept back:
    pve-manager qemu-server
    The following packages will be upgraded:
    apache2 apache2-mpm-prefork apache2-utils apache2.2-common apt apt-utils base-files bind9-host dhcp3-client dhcp3-common dnsutils dpkg
    gnupg gpgv gzip libapr1 libaprutil1 libbind9-40 libc6 libc6-i386 libcompress-raw-zlib-perl libdns45 libexpat1 libfreetype6 libgd2-noxpm
    libgnutls26 libhtml-parser-perl libio-socket-ssl-perl libisc45 libisccc40 libisccfg40 libjs-prototype libkrb53 libldap-2.4-2 liblwres40
    libmysqlclient15off libnewt0.52 libperl5.10 libpq5 libsasl2-2 libsmbclient libssl0.9.8 libvolume-id0 libwbclient0 libxcb-xlib0 libxcb1
    libxml2 locales login mysql-common ntp openssl passwd perl perl-base perl-modules perl-suid pve-firmware pve-kernel-2.6.24-7-pve
    python2.5 python2.5-minimal samba-common smbfs tzdata udev usbutils vzctl vzdump wget whiptail x11-common
    71 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
    Need to get 98.2MB of archives.
    After this operation, 1847kB disk space will be freed.
    Do you want to continue [Y/n]? y
    Get:1 http://download.proxmox.com lenny/pve libjs-prototype 1.6.0.3-1 [33.1kB]
    ...
    ...
    ...
    Setting up libcompress-raw-zlib-perl (2.012-1lenny1) ...
    Setting up libhtml-parser-perl (3.56-1+lenny1) ...
    Setting up libio-socket-ssl-perl (1.16-1+lenny1) ...
    Setting up vzdump (1.2-5) ...
    proxmox2:~#


    ***** The pveversion output after 'apt-get upgrade' *****
    proxmox2:~# pveversion --verbose
    pve-manager: 1.3-1 (pve-manager/1.3/4023)
    qemu-server: 1.0-14
    pve-kernel: 2.6.24-8
    pve-kvm: 86-1
    pve-firmware: 1.0-3
    vncterm: 0.9-2
    vzctl: 3.0.23-1pve8
    vzdump: 1.2-5
    vzprocps: 2.0.11-1dso2
    vzquota: 3.0.11-1
    proxmox2:~#


    ***** Starting install of proxmox-ve-2.6.24 *****
    proxmox2:~# apt-get install proxmox-ve-2.6.24
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following extra packages will be installed:
    busybox initramfs-tools klibc-utils libfilesys-df-perl libklibc libpve-storage-perl pve-kernel-2.6.24-10-pve pve-qemu-kvm qemu-server
    The following packages will be REMOVED:
    proxmox-ve pve-kernel pve-kvm
    The following NEW packages will be installed:
    busybox initramfs-tools klibc-utils libfilesys-df-perl libklibc libpve-storage-perl proxmox-ve-2.6.24 pve-kernel-2.6.24-10-pve
    pve-qemu-kvm
    The following packages will be upgraded:
    qemu-server
    1 upgraded, 9 newly installed, 3 to remove and 1 not upgraded.
    Need to get 43.0MB of archives.
    After this operation, 2028kB of additional disk space will be used.
    Do you want to continue [Y/n]? y
    Get:1 http://ftp.debian.org lenny/main libfilesys-df-perl 0.92-3+b1 [14.6kB]
    Get:2 http://download.proxmox.com lenny/pve qemu-server 1.1-11 [53.5kB]
    Get:3 http://ftp.debian.org lenny/main busybox 1:1.10.2-2 [335kB]
    Get:4 http://download.proxmox.com lenny/pve pve-qemu-kvm 0.11.1-2 [1787kB]
    Get:5 http://ftp.debian.org lenny/main libklibc 1.5.12-2 [46.5kB]
    Get:6 http://ftp.debian.org lenny/main klibc-utils 1.5.12-2 [182kB]
    Get:7 http://ftp.debian.org lenny/main initramfs-tools 0.92o [75.3kB]
    Get:8 http://download.proxmox.com lenny/pve libpve-storage-perl 1.0-10 [23.6kB]
    Get:9 http://download.proxmox.com lenny/pve pve-kernel-2.6.24-10-pve 2.6.24-21 [40.5MB]
    Get:10 http://download.proxmox.com lenny/pve proxmox-ve-2.6.24 1.5-21 [4084B]
    Fetched 43.0MB in 4min7s (174kB/s)
    (Reading database ... 24972 files and directories currently installed.)
    Removing proxmox-ve ...
    Removing pve-kernel ...
    (Reading database ... 24969 files and directories currently installed.)
    Preparing to replace qemu-server 1.0-14 (using .../qemu-server_1.1-11_amd64.deb) ...
    Unpacking replacement qemu-server ...
    Processing triggers for man-db ...
    (Reading database ... 24965 files and directories currently installed.)
    Removing pve-kvm ...
    Processing triggers for man-db ...
    Selecting previously deselected package pve-qemu-kvm.
    (Reading database ... 24903 files and directories currently installed.)
    Unpacking pve-qemu-kvm (from .../pve-qemu-kvm_0.11.1-2_amd64.deb) ...
    Selecting previously deselected package libfilesys-df-perl.
    Unpacking libfilesys-df-perl (from .../libfilesys-df-perl_0.92-3+b1_amd64.deb) ...
    Selecting previously deselected package libpve-storage-perl.
    Unpacking libpve-storage-perl (from .../libpve-storage-perl_1.0-10_all.deb) ...
    Selecting previously deselected package busybox.
    Unpacking busybox (from .../busybox_1%3a1.10.2-2_amd64.deb) ...
    Selecting previously deselected package libklibc.
    Unpacking libklibc (from .../libklibc_1.5.12-2_amd64.deb) ...
    Selecting previously deselected package klibc-utils.
    Unpacking klibc-utils (from .../klibc-utils_1.5.12-2_amd64.deb) ...
    Selecting previously deselected package initramfs-tools.
    Unpacking initramfs-tools (from .../initramfs-tools_0.92o_all.deb) ...
    Selecting previously deselected package pve-kernel-2.6.24-10-pve.
    Unpacking pve-kernel-2.6.24-10-pve (from .../pve-kernel-2.6.24-10-pve_2.6.24-21_amd64.deb) ...
    Selecting previously deselected package proxmox-ve-2.6.24.
    Unpacking proxmox-ve-2.6.24 (from .../proxmox-ve-2.6.24_1.5-21_all.deb) ...
    Processing triggers for man-db ...
    Setting up pve-qemu-kvm (0.11.1-2) ...
    Setting up libfilesys-df-perl (0.92-3+b1) ...
    Setting up libpve-storage-perl (1.0-10) ...
    Setting up qemu-server (1.1-11) ...
    Setting up busybox (1:1.10.2-2) ...
    Setting up libklibc (1.5.12-2) ...
    Setting up klibc-utils (1.5.12-2) ...
    Setting up initramfs-tools (0.92o) ...
    update-initramfs: deferring update (trigger activated)
    Setting up pve-kernel-2.6.24-10-pve (2.6.24-21) ...
    update-initramfs: Generating /boot/initrd.img-2.6.24-10-pve
    Searching for GRUB installation directory ... found: /boot/grub
    Searching for default file ... found: /boot/grub/default
    Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
    Searching for splash image ... none found, skipping ...
    Found kernel: /vmlinuz-2.6.24-10-pve
    Found kernel: /vmlinuz-2.6.24-7-pve
    Found kernel: /memtest86+.bin
    Updating /boot/grub/menu.lst ... done

    Setting up proxmox-ve-2.6.24 (1.5-21) ...
    installing proxmox release key: OK
    Processing triggers for initramfs-tools ...
    update-initramfs: Generating /boot/initrd.img-2.6.24-10-pve
    proxmox2:~#


    ***** The pveversion output after 'apt-get install proxmox-ve-2.6.24' *****
    proxmox2:~# pveversion --verbose
    pve-manager: 1.3-1 (pve-manager/1.3/4023)
    qemu-server: 1.1-11
    pve-kernel: not correctly installed
    pve-kvm: not correctly installed
    pve-firmware: 1.0-3
    vncterm: 0.9-2
    vzctl: 3.0.23-1pve8
    vzdump: 1.2-5
    vzprocps: 2.0.11-1dso2
    vzquota: 3.0.11-1
    proxmox2:~# dpkg -l | grep pve
    ii libpve-storage-perl 1.0-10 Proxmox VE storage management library
    ii pve-firmware 1.0-3 Binary firmware code for the pve-kernel
    ii pve-kernel-2.6.24-10-pve 2.6.24-21 The Proxmox PVE Kernel Image
    ii pve-kernel-2.6.24-7-pve 2.6.24-11 The Proxmox PVE Kernel Image
    rc pve-kvm 86-1 Full virtualization on x86 hardware
    ii pve-manager 1.3-1 The Proxmox Virtul Environment
    ii pve-qemu-kvm 0.11.1-2 Full virtualization on x86 hardware
    ii vzctl 3.0.23-1pve8 OpenVZ - server virtualization solution - co
    proxmox2:~#


    Any help on this is appreciated.


    Thanks,

  2. #2
    Join Date
    Apr 2005
    Location
    Austria
    Posts
    12,101

    Default Re: Problems in upgrade from 1.3 to 1.5

    still the old pve-manager version. What is you run apt again:

    # apt-get update
    # apt-get install

  3. #3
    Join Date
    Dec 2009
    Posts
    16

    Default Re: Problems in upgrade from 1.3 to 1.5

    Here's the output .......

    proxmox2:~# apt-get update
    Hit http://ftp.debian.org lenny Release.gpg
    Ign http://ftp.debian.org lenny/main Translation-en_US
    Ign http://ftp.debian.org lenny/contrib Translation-en_US
    Hit http://ftp.debian.org lenny Release
    Ign http://ftp.debian.org lenny/main Packages/DiffIndex
    Ign http://ftp.debian.org lenny/contrib Packages/DiffIndex
    Hit http://ftp.debian.org lenny/main Packages
    Hit http://ftp.debian.org lenny/contrib Packages
    Hit http://download.proxmox.com lenny Release.gpg
    Ign http://download.proxmox.com lenny/pve Translation-en_US
    Hit http://security.debian.org lenny/updates Release.gpg
    Ign http://security.debian.org lenny/updates/main Translation-en_US
    Ign http://security.debian.org lenny/updates/contrib Translation-en_US
    Hit http://download.proxmox.com lenny Release
    Hit http://security.debian.org lenny/updates Release
    Ign http://download.proxmox.com lenny/pve Packages/DiffIndex
    Ign http://security.debian.org lenny/updates/main Packages/DiffIndex
    Ign http://download.proxmox.com lenny/pve Packages
    Ign http://security.debian.org lenny/updates/contrib Packages/DiffIndex
    Hit http://download.proxmox.com lenny/pve Packages
    Hit http://security.debian.org lenny/updates/main Packages
    Hit http://security.debian.org lenny/updates/contrib Packages
    Reading package lists... Done
    proxmox2:~#
    proxmox2:~# apt-get install
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
    proxmox2:~#
    proxmox2:~# apt-get install proxmox-ve-2.6.24
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    proxmox-ve-2.6.24 is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
    proxmox2:~#

    Thanks,

  4. #4
    Join Date
    Apr 2005
    Location
    Austria
    Posts
    12,101

    Default Re: Problems in upgrade from 1.3 to 1.5

    Sorry, just saw that you already done what I suggested - strange.

  5. #5
    Join Date
    Apr 2005
    Location
    Austria
    Posts
    12,101

    Default Re: Problems in upgrade from 1.3 to 1.5

    try

    # apt-get install pve-manager

  6. #6
    Join Date
    Dec 2009
    Posts
    16

    Default Re: Problems in upgrade from 1.3 to 1.5

    We faced the same issue on another test setup and ran "apt-get upgrade pve-kernel" and it worked. We tried your suggested step and that worked as well:

    proxmox2:~# pveversion --verbose
    pve-manager: 1.5-8 (pve-manager/1.5/4674)
    running kernel: 2.6.24-10-pve
    proxmox-ve-2.6.24: 1.5-21
    pve-kernel-2.6.24-10-pve: 2.6.24-21
    qemu-server: 1.1-11
    pve-firmware: 1.0-3
    libpve-storage-perl: 1.0-10
    vncterm: 0.9-2
    vzctl: 3.0.23-1pve8
    vzdump: 1.2-5
    vzprocps: 2.0.11-1dso2
    vzquota: 3.0.11-1
    pve-qemu-kvm: 0.11.1-2
    proxmox2:~#


    However, we are surprised as to why it doesn't work on the first attempt, when we ran
    apt-get install proxmox-ve-2.6.24.

    Thanks for your prompt replies.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •