Proxmox 3.3 + vSWITCH + BOND + VLAN

I'm 100% sure that all is correct now on openvswitch,

So I don't understand why it's not working.

(Do you kernel 3.10 or 2.6.32 ? I think kernel 3.10 works better with ovs and vlan).

Are you sure that you physical switch is correctly configured ? (does it work with linux bridges ?).
are you sure that is eth0 and eth1 are the correct interfaces for bond0 ?

Hi,

I'm using 3.10 kernel. And all interfaces are working with linux bridges. In fact, I just switch config to linux bridging everytime I will have to copy the config and copy command results to you. I'm also sure that eth0 and eth1 are correct interfaces. In fact just to be sure I'm using ethtool to check which interface is active and switch between interfaces to really see.

I would like to thank you for all the efforts, I'll try to take it from here.

Have a nice day!!!
 
Last edited:
Hi Spirit,

I was able to create an exact config output (the one you created) but this time using the GUI. However, I still can't access the Proxmox server from a directly connection host. This made me wonder, is the config made to allow a host to access the Proxmox Server on Web Management IP 192.168.125.10?? Because even if it was done from the GUI I still can't access it.

Hope you can shed light on this issue. I've been stuck with this problem for a long time. Actually, I even replaced my NIC with a new one but the problem seem the same.

Also, this promox machine is newly installed. I don't have any VM running inside it. This development server would replace our production server but I cannot go any further because of this problem.

Any help will be greatly appreciated.

OVS Setup via gui.jpg

Thanks alot!
 
Last edited:
Yes, I don't see any reason why It should not work.

I have it in production without any problem.

(Note that if you configure through gui, the config is write to /etc/network/interfaces.new , and this file is copied on host reboot to /etc/network/interfaces)
so you need to reboot.


I'm using cisco switches, and I simply configure the port in trunk mode, to allow vlans tagged on proxmox host, to go through the switch.
 
Yes, I don't see any reason why It should not work.

I have it in production without any problem.

(Note that if you configure through gui, the config is write to /etc/network/interfaces.new , and this file is copied on host reboot to /etc/network/interfaces)
so you need to reboot.


I'm using cisco switches, and I simply configure the port in trunk mode, to allow vlans tagged on proxmox host, to go through the switch.

Yes, I rebooted the server and have seen all the interfaces to come up except vmbr1, which I have to manually activate.

root@prox10:~# ovs-vsctl show
2cef8468-d63f-4b9c-ab02-5d7fdaa56550
Bridge "vmbr1"
Port "vlan100"
tag: 100
Interface "vlan100"
type: internal
Port "vlan10"
tag: 10
Interface "vlan10"
type: internal
Port "vlan125"
tag: 125
Interface "vlan125"
type: internal
Port "bond0"
Interface "eth3"
Interface "eth0"
Port "vmbr1"
Interface "vmbr1"
type: internal
ovs_version: "2.3.0"

I'm also using cisco switches and vlans are configured properly and the port where Proxmox is attached is configured in trunk mode. But I still can't manage it to work.

I'm so lost here.
 
Last edited:
can you send your last /etc/network/interfaces and your cisco switch config ?

Here's the cisco config:
Code:
interface GigabitEthernet0/24
 description ***TRUNK PORT TO PROXMOX SERVER***
 switchport trunk allowed vlan 10,100,125
 switchport mode trunk
!
interface Vlan1
 no ip address
 no ip route-cache
!
interface Vlan10
 ip address 192.168.3.3 255.255.255.0
 no ip route-cache
!
interface Vlan125
 ip address 192.168.125.3 255.255.255.0
 no ip route-cache


Here's the /etc/network/interface config:

Code:
# network interface settings
allow-vmbr1 vlan10
iface vlan10 inet static
    address  192.168.3.10
    netmask  255.255.255.0
    ovs_type OVSIntPort
    ovs_bridge vmbr1
    ovs_options tag=10

allow-vmbr1 vlan100
iface vlan100 inet static
    address  192.168.100.10
    netmask  255.255.255.0
    ovs_type OVSIntPort
    ovs_bridge vmbr1
    ovs_options tag=100

allow-vmbr1 vlan125
iface vlan125 inet static
    address  192.168.125.13
    netmask  255.255.255.0
    ovs_type OVSIntPort
    ovs_bridge vmbr1
    ovs_options tag=125

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet manual

auto eth2
iface eth2 inet manual

iface eth1 inet manual

auto eth3
iface eth3 inet manual

allow-vmbr1 bond0
iface bond0 inet manual
    ovs_bonds eth0 eth3
    ovs_type OVSBond
    ovs_bridge vmbr1
    ovs_options lacp=active bond_mode=balance-tcp

auto vmbr1
iface vmbr1 inet manual
    ovs_type OVSBridge
    ovs_ports bond0 vlan10 vlan100 vlan125
 
Last edited:
Where is your port-channel config ?

Here's the config for port-channel.

Code:
interface GigabitEthernet0/24
 description ***TRUNK PORT TO PROXMOX SERVER***
 switchport trunk allowed vlan 10,100,125
 switchport mode trunk
 channel-protocol lacp
 channel-group 1 mode active

I only need the port-channel config to the TRUNK PORT right?

Anyway, I can now ping the cisco switch from proxmox. :) Yahoo!!!!

Many, many thanks!!!
 
Last edited:
>>I only need the port-channel config to the TRUNK PORT right?

Well, no ... You need to configure 1 port channel, and configure 2 ports. (with 1 port, why do you want bonding ?)

I think it was working with linux-bridge, because they are a fallback if lacp can't be negociated.

you should have something like

Code:
[/COLOR]interface Port-channel1 
 switchport trunk allowed vlan 10,100,125
 switchport mode trunk
 channel-protocol lacp
!
interface GigabitEthernet0/24
 description ***TRUNK PORT TO PROXMOX SERVER***
 switchport trunk allowed vlan 10,100,125
 switchport mode trunk
 channel-protocol lacp
 channel-group 1 mode active

interface GigabitEthernet0/23 (or another port)
 description ***TRUNK PORT TO PROXMOX SERVER***
 switchport trunk allowed vlan 10,100,125
 switchport mode trunk
 channel-protocol lacp
 channel-group 1 mode active


Applying config on port-channel, apply it on port-channel members
 
Re: Proxmox 3.3 + vSWITCH + BOND + VLAN [SOLVED]

>>I only need the port-channel config to the TRUNK PORT right?

Well, no ... You need to configure 1 port channel, and configure 2 ports. (with 1 port, why do you want bonding ?)

I think it was working with linux-bridge, because they are a fallback if lacp can't be negociated.

you should have something like

Code:
Code:
interface Port-channel1 
 switchport trunk allowed vlan 10,100,125
 switchport mode trunk
 channel-protocol lacp
!
interface GigabitEthernet0/24
 description ***TRUNK PORT TO PROXMOX SERVER***
 switchport trunk allowed vlan 10,100,125
 switchport mode trunk
 channel-protocol lacp
 channel-group 1 mode active

interface GigabitEthernet0/23 (or another port)
 description ***TRUNK PORT TO PROXMOX SERVER***
 switchport trunk allowed vlan 10,100,125
 switchport mode trunk
 channel-protocol lacp
 channel-group 1 mode active


Applying config on port-channel, apply it on port-channel members

Hi Spirit,

Yes, I applied port-channel on the port-channel and port-channel members. Also, I have 2 trunk-ports configured.

It's working alright. Thanks for all you support!!

:)
 
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!