PDA

View Full Version : Kernel 2.6.35-11 on DELL Precision T3500



WaltervdSchee
05-19-2011, 02:32 PM
Hello all,

I've installed the excellent ProxMox VE 1.8 on a DELL Precision T3500, currently using it as a test machine for some product testing.
It installed fine using the 2.6.32 kernel it came with, in AHCI mode for the Intel SATA controller.

After installation of the 2.6.35-11 kernel it failed to boot with ahci errors.

Just for completeness :

output of pveversion -v

pve-manager: 1.8-17 (pve-manager/1.8/5948)
running kernel: 2.6.32-4-pve
proxmox-ve-2.6.35: 1.8-11
pve-kernel-2.6.32-4-pve: 2.6.32-33
pve-kernel-2.6.35-1-pve: 2.6.35-11
qemu-server: 1.1-30
pve-firmware: 1.0-11
libpve-storage-perl: 1.0-17
vncterm: 0.9-2
vzctl: 3.0.26-1pve4
vzdump: 1.2-12
vzprocps: 2.0.11-2
vzquota: 3.0.11-1
pve-qemu-kvm: 0.14.0-3
ksm-control-daemon: 1.0-5Here's the error:


ahci 0000:00:1f.2: controller reset failed (0xffffffff)
ahci 0000:00:1f.2: failed to stop engine (-5)
ahci 0000:00:1f.2: failed to stop engine (-5)
ahci 0000:00:1f.2: failed to stop engine (-5)
ahci 0000:00:1f.2: failed to stop engine (-5)
ahci 0000:00:1f.2: failed to stop engine (-5)
ahci 0000:00:1f.2: failed to stop engine (-5)
.....

BUG: unable to handle kernel paging request at ffffc9000186d018
Oops: 0000 [#1] SMP

Output of lspci -v for the involved device:


00:1f.2 SATA controller: Intel Corporation 82801JI (ICH10 Family) SATA AHCI Controller (prog-if 01 [AHCI 1.0])
Subsystem: Dell Device 0293
Flags: bus master, 66MHz, medium devsel, latency 0, IRQ 54
I/O ports at fe00 [size=8]
I/O ports at fe10 [size=4]
I/O ports at fe20 [size=8]
I/O ports at fe30 [size=4]
I/O ports at fec0 [size=32]
Memory at ff970000 (32-bit, non-prefetchable) [size=2K]
Capabilities: [80] Message Signalled Interrupts: Mask- 64bit- Queue=0/4 Enable+
Capabilities: [70] Power Management version 3
Capabilities: [a8] SATA HBA <?>
Capabilities: [b0] PCIe advanced features <?>
Kernel driver in use: ahci
Kernel modules: ahci

I can still use 2.6.32 kernel, but I'd like to use 2.6.35 due to the KSM features.

Anybody know about some AHCI based problems with 2.6.35-11 with DELL hardware ?