PDA

View Full Version : External VNC viewer?



wacked
08-22-2008, 04:21 AM
I have Java issues and would like to use an external vncviewer (Win32) to connect to a VM. I tried to connect to VMID 101 with the command line:

vncviewer 192.168.0.60:101

got an connection refused error and turns out that there's not even a VNC server listening (at port 5900). Is is possible to use an extern vnc viewer to connect to the VM's? :confused:

dietmar
08-22-2008, 08:37 AM
no, there is no vnc server listening, but you can start a server with:



nc -l -p 5900 -c "qm vncproxy VMID PASSWORD"


After that you can connect one time (because PASSWORD is a one time ticket).

- Dietmar

pjo
08-22-2008, 10:50 AM
I'm also interested in solving that issue.
I've tried the solution above but all I got is: "Not a valid VNC server".

I've tried also to forward a vnc connection from a kvm machine.
I've used socat (piping from /tmp/qemu-server-vnc-ID.socket to tcp socket) and been close to success: vnc viewer saw a server.
But I can not figure out what password should use to authenticate.
BTW "change vnc password" does not work in QM.

Best regards
Pawel

pjo
08-22-2008, 01:07 PM
OK, that works for kvm, so socat is not needed.
But what to do to get external vnc viewer to work with ovz? The solution above does not work ("Not a valid VNC server").

And just out of curiosity: how to pass authentication when trying to connect to the unix socket: /tmp/qemu-server-vnc-ID.socket?


Best regards
Pawel

tom
08-22-2008, 02:06 PM
OK, that works for kvm, so socat is not needed.
But what to do to get external vnc viewer to work with ovz? The solution above does not work ("Not a valid VNC server").

And just out of curiosity: how to pass authentication when trying to connect to the unix socket: /tmp/qemu-server-vnc-ID.socket?


Best regards
Pawel

for openvz container just connect remotely via ssh, why do you want to use vnc here?

pjo
08-22-2008, 02:53 PM
for openvz container just connect remotely via ssh, why do you want to use vnc here?

I can image such a situation: one can create and start a container from web interface so the container network is not configured yet.
And provided vnc viewer can't be started (e.g. problems w/ java plugin version).

regards
Pawel

tom
08-22-2008, 03:56 PM
I can image such a situation: one can create and start a container from web interface so the container network is not configured yet.
And provided vnc viewer can't be started (e.g. problems w/ java plugin version).

regards
Pawel

in such a case connect via ssh to the Proxmox VE and then:


vzctl enter VMID

the host can access all containers without the need of a running network.

wacked
08-22-2008, 03:58 PM
no, there is no vnc server listening, but you can start a server with:



nc -l -p 5900 -c "qm vncproxy VMID PASSWORD"


After that you can connect one time (because PASSWORD is a one time ticket).

- Dietmar
Thanks, works great.

wacked.

dietmar
08-22-2008, 06:30 PM
OK, that works for kvm, so socat is not needed.
But what to do to get external vnc viewer to work with ovz? The solution above does not work ("Not a valid VNC server").


We use vncterm for that:



vncterm [VNCOPTS] [-c command [ARGS]]

#example:
vncterm -c vzctl enter VMID

vncterm -rfbport 5900 -passwdfile FILE -timeout 20 -c vzctl enter 104



that way you can proxy any application.

- Dietmar

pjo
08-25-2008, 01:56 PM
We use vncterm for that:
[...]
- Dietmar

Great! It works much faster. Thanks a lot.
BTW Where I can learn more about vncterm? Its man page is not informative very much ;)

dietmar
08-25-2008, 02:20 PM
The source code is available at ftp://pve.proxmox.com/sources/

- Dietmar

clipcarl
08-27-2008, 11:47 PM
I added this to my /etc/inetd.conf so that I can always connect to my VMs with an external viewer:
9001 stream tcp nowait root /usr/sbin/qm qm vncproxy 101 SecretPassword
9002 stream tcp nowait root /usr/sbin/qm qm vncproxy 102 SecretPassword
9003 stream tcp nowait root /usr/sbin/qm qm vncproxy 103 SecretPassword
9004 stream tcp nowait root /usr/sbin/qm qm vncproxy 104 SecretPassword
9005 stream tcp nowait root /usr/sbin/qm qm vncproxy 105 SecretPassword
9006 stream tcp nowait root /usr/sbin/qm qm vncproxy 106 SecretPassword
9007 stream tcp nowait root /usr/sbin/qm qm vncproxy 107 SecretPassword
9008 stream tcp nowait root /usr/sbin/qm qm vncproxy 108 SecretPassword

djbon2112
09-27-2008, 05:46 AM
I added this to my /etc/inetd.conf so that I can always connect to my VMs with an external viewer:
9001 stream tcp nowait root /usr/sbin/qm qm vncproxy 101 SecretPassword
9002 stream tcp nowait root /usr/sbin/qm qm vncproxy 102 SecretPassword
9003 stream tcp nowait root /usr/sbin/qm qm vncproxy 103 SecretPassword
9004 stream tcp nowait root /usr/sbin/qm qm vncproxy 104 SecretPassword
9005 stream tcp nowait root /usr/sbin/qm qm vncproxy 105 SecretPassword
9006 stream tcp nowait root /usr/sbin/qm qm vncproxy 106 SecretPassword
9007 stream tcp nowait root /usr/sbin/qm qm vncproxy 107 SecretPassword
9008 stream tcp nowait root /usr/sbin/qm qm vncproxy 108 SecretPassword
What about that is configurable for my local settings, assuming I use the user 'root' for Proxmox, 'administrator' for all the VMs, and a single password for them all? Also, what would I type into my terminal server client (the app of the same name in Ubuntu) to access the VMs?

clipcarl
09-27-2008, 05:11 PM
What about that is configurable for my local settings, assuming I use the user 'root' for Proxmox, 'administrator' for all the VMs, and a single password for them all? Also, what would I type into my terminal server client (the app of the same name in Ubuntu) to access the VMs?

Each line added to the file represents a Proxmox VE virtual machine that you want to be able to connect to externally. In my example 101 through 108.

The first column is the port you want to listen on for a particular VM (penultimate column). That is of course configurable.

The last column is the password you want to use to connect to the VNC server. This has nothing to do with users or passwords on the virtual machine. It's best to think of the VNC server as simply a virtual monitor, keyboard and mouse. Like any monitor keyboard and mouse, the VNC server knows nothing about what OS your running or its users so this password has nothing to do with the users or passwords on your virtual machine. This password is simply used to access the VNC server (as if your keyboard and mouse required a password to use).

Don't use Terminal Server Client for VNC servers. It just runs vncviewer which is really, really slow. Use Vinagre instead which I think is a standard Gnome app. In the "Connect" dialog use the hostname or IP of the Proxmox VE server (not of your VM) and the port for the VM you set up in the inetd.conf file. When it connects Vinagre will ask you for the password for the VNC server which is the one in the inetd.conf file. Once you're connected you will see what you normally would see on a monitor-- a login prompt or login dialog depending on the OS on the VM.

It's worth noting that the OS sees this as its regular monitor and keyboard so if it's configured to blank the screen after a period of inactivity you may need to hit a key to see anything at all.

It's also worth noting that just like a regular monitor, keyboard and mouse the VNC server has no concept of cut and paste. You can't cut something on your local machine running Vinagre and paste it into your VM. You can of course cut and paste entirely within the VM as usual. So if cut and paste is something you need you should use Remote Desktop for Windows virtual machines or some other method for other virtal machines.

clipcarl
09-27-2008, 05:17 PM
I added this to my /etc/inetd.conf so that I can always connect to my VMs with an external viewer:
9001 stream tcp nowait root /usr/sbin/qm qm vncproxy 101 SecretPassword
9002 stream tcp nowait root /usr/sbin/qm qm vncproxy 102 SecretPassword
9003 stream tcp nowait root /usr/sbin/qm qm vncproxy 103 SecretPassword
9004 stream tcp nowait root /usr/sbin/qm qm vncproxy 104 SecretPassword
9005 stream tcp nowait root /usr/sbin/qm qm vncproxy 105 SecretPassword
9006 stream tcp nowait root /usr/sbin/qm qm vncproxy 106 SecretPassword
9007 stream tcp nowait root /usr/sbin/qm qm vncproxy 107 SecretPassword
9008 stream tcp nowait root /usr/sbin/qm qm vncproxy 108 SecretPassword

I should have mentioned that I don't think inetd is installed on Proxmox VE by default. So to use this you need to run

apt-get install openbsd-inetd
on the Proxmox VE server as root.

alphadog
03-21-2009, 10:44 PM
Anyone ever try xinetd, since it is already installed in the PVE?

I tried to create a file in /etc/xinetd.d:

service vnc-200
{
socket_type = stream
protocol = tcp
port = 9000
wait = no
user = root
server = /usr/sbin/qm
server_args = vncproxy 200 windowsvnc
}

Then, from a Win box, I try to access the VM via 192.168.x.y:9000, but I get a connection refused.

Any suggestions?

dietmar
03-23-2009, 10:59 AM
There seems to be a confusion about the installed inetd.

By default, we install 'openbsd-inetd'

- Dietmar

Neoscopio
03-31-2009, 07:25 PM
BTW, I have some java issues as well, but only with one of my recently installed proxmox boxes. I've installed 2 machines, both with the same iso, and one of them works great, but the other one has no java vnc viewer (laptop with ff3, sun's java, ubuntu). Reinstall did nothing. Anyone else has these problems? I can work around them but the java vnc viewer is useful at times.

Thanks

Giovanni
04-08-2009, 02:35 PM
I'm also interested in solving that issue.
I've tried the solution above but all I got is: "Not a valid VNC server".

I've tried also to forward a vnc connection from a kvm machine.
I've used socat (piping from /tmp/qemu-server-vnc-ID.socket to tcp socket) and been close to success: vnc viewer saw a server.
But I can not figure out what password should use to authenticate.
BTW "change vnc password" does not work in QM.

Best regards
Pawel

What password are you using to authenticate? I tried the command Tom mentioned, VNCviewer (windows) asks only for a password, I tried with the rootpw, blank, space they all fail and "nc" drops the connection.

DaveQB
04-16-2009, 12:12 AM
no, there is no vnc server listening, but you can start a server with:



nc -l -p 5900 -c "qm vncproxy VMID PASSWORD"
After that you can connect one time (because PASSWORD is a one time ticket).

- Dietmar


This sounds promising, but I get here:

"Not a valid VNC server"

Tried vncviewer and krdc

Any suggestions most appreciated.

DaveQB
04-16-2009, 12:14 AM
in such a case connect via ssh to the Proxmox VE and then:


vzctl enter VMIDthe host can access all containers without the need of a running network.

Thank you, thank you, thank you!!!

I have been looking for the OpenVZ equivalent of xm vm_name console
I was beginning to think it was not possible.

dietmar
04-16-2009, 08:59 AM
Try to debug with telnet:

# telnet IPADDRESS 5900

to see if the vnc server is answering. Or try to use another port.

- Dietmar

DaveQB
04-16-2009, 11:49 AM
Try to debug with telnet:

# telnet IPADDRESS 5900

to see if the vnc server is answering. Or try to use another port.

- Dietmar


Cool thanks. I get



root@devel:~# telnet 10.33.33.131 5900
Trying 10.33.33.131...
Connected to 10.33.33.131.
Escape character is '^]'.
RFB 003.008



And hangs there, waiting for some stream.

Now to search this string...
http://www.google.com.au/search?q=RFB+003.008

dietmar
04-16-2009, 12:59 PM
Cool thanks. I get



root@devel:~# telnet 10.33.33.131 5900
Trying 10.33.33.131...
Connected to 10.33.33.131.
Escape character is '^]'.
RFB 003.008




So the VNC server works perfectly.

DaveQB
04-16-2009, 11:56 PM
I tried and tried and tried yesterday and suddenly it started working. Bugger me if I know why it wasn't, I didn't change anything in the process.

Thanks guys!!

PS I would recommend a tick box option in the web GUI to allow external VNC viewing to a VM in Proxmox. That would be the icing on the cake with this beautiful server software! :D
PSS Hmmm maybe I can look at implementing this myself

DaveQB
04-17-2009, 12:02 AM
I added this to my /etc/inetd.conf so that I can always connect to my VMs with an external viewer:
9001 stream tcp nowait root /usr/sbin/qm qm vncproxy 101 SecretPassword
9002 stream tcp nowait root /usr/sbin/qm qm vncproxy 102 SecretPassword
9003 stream tcp nowait root /usr/sbin/qm qm vncproxy 103 SecretPassword
9004 stream tcp nowait root /usr/sbin/qm qm vncproxy 104 SecretPassword
9005 stream tcp nowait root /usr/sbin/qm qm vncproxy 105 SecretPassword
9006 stream tcp nowait root /usr/sbin/qm qm vncproxy 106 SecretPassword
9007 stream tcp nowait root /usr/sbin/qm qm vncproxy 107 SecretPassword
9008 stream tcp nowait root /usr/sbin/qm qm vncproxy 108 SecretPassword

Nice work clipcarl!!! :cool:

DaveQB
04-17-2009, 11:58 PM
I added this to my /etc/inetd.conf so that I can always connect to my VMs with an external viewer:
9001 stream tcp nowait root /usr/sbin/qm qm vncproxy 101 SecretPassword
9002 stream tcp nowait root /usr/sbin/qm qm vncproxy 102 SecretPassword
9003 stream tcp nowait root /usr/sbin/qm qm vncproxy 103 SecretPassword
9004 stream tcp nowait root /usr/sbin/qm qm vncproxy 104 SecretPassword
9005 stream tcp nowait root /usr/sbin/qm qm vncproxy 105 SecretPassword
9006 stream tcp nowait root /usr/sbin/qm qm vncproxy 106 SecretPassword
9007 stream tcp nowait root /usr/sbin/qm qm vncproxy 107 SecretPassword
9008 stream tcp nowait root /usr/sbin/qm qm vncproxy 108 SecretPassword



Is it right that this only works for KVM and not OpenVZ VM's?

I have OpenVZ VM's on 5901 and 5902 and KVM VM's on 5903 and 5904.

[code]
david@david ~ $
telnet 10.33.33.131 5901
Trying 10.33.33.131...
Connected to 10.33.33.131.
Escape character is '^]'.
unable to find configuration file for VM 101 - no such machine
Connection closed by foreign host.
david@david ~ $
telnet 10.33.33.131 5902
Trying 10.33.33.131...
Connected to 10.33.33.131.
Escape character is '^]'.
unable to find configuration file for VM 102 - no such machine
Connection closed by foreign host.
david@david ~ $
telnet 10.33.33.131 5903
Trying 10.33.33.131...
Connected to 10.33.33.131.
Escape character is '^]'.
RFB 003.008
Connection closed by foreign host.
david@david ~ $
telnet 10.33.33.131 5904
Trying 10.33.33.131...
Connected to 10.33.33.131.
Escape character is '^]'.
RFB 003.008
Connection closed by foreign host.

dietmar
05-13-2009, 11:44 AM
you can use vncterm for that



vncterm --rfbport 5900 -c vzctl enter 777

BiagioParuolo
09-15-2009, 03:56 PM
Then.. with
/usr/sbin/qm qm vncproxy 101 SecretPassword
Is it possible to transfer file directly to/from Guest VM 101 with VNC client ( like UltraVNC ) if I disable temporanealy VM 101 Network?

tom
09-15-2009, 10:42 PM
Then.. with
/usr/sbin/qm qm vncproxy 101 SecretPassword
Is it possible to transfer file directly to/from Guest VM 101 with VNC client ( like UltraVNC ) if I disable temporanealy VM 101 Network?

I don´t think that this is possible here but never tried.

zordio
10-07-2009, 11:14 PM
This works great for KVM guests, but I have not been able to figure out a command line to have vncterm started from inetd. I always get a "connection refused" error. I looked through the x11vnc man page, but from what I can see, vncterm does not support most of the x11vnc options.

vncterm does work from the command line (for a single session).

The simplest thing I tried was:


5902 stream tcp nowait root /usr/bin/vncterm -inetd -c vzctl enter 102

dietmar
10-08-2009, 09:57 AM
vncterm does work from the command line (for a single session).

Yes, seems that vncterm does not work with -inetd

Robstarusa
11-01-2009, 04:51 PM
I added this to my /etc/inetd.conf so that I can always connect to my VMs with an external viewer:
9001 stream tcp nowait root /usr/sbin/qm qm vncproxy 101 SecretPassword
9002 stream tcp nowait root /usr/sbin/qm qm vncproxy 102 SecretPassword
9003 stream tcp nowait root /usr/sbin/qm qm vncproxy 103 SecretPassword
9004 stream tcp nowait root /usr/sbin/qm qm vncproxy 104 SecretPassword
9005 stream tcp nowait root /usr/sbin/qm qm vncproxy 105 SecretPassword
9006 stream tcp nowait root /usr/sbin/qm qm vncproxy 106 SecretPassword
9007 stream tcp nowait root /usr/sbin/qm qm vncproxy 107 SecretPassword
9008 stream tcp nowait root /usr/sbin/qm qm vncproxy 108 SecretPassword

This works awesome!!! Of course I changed SecretPassword to something else :)

typo3usa
11-18-2009, 08:22 AM
having issues getting this to work for 1.4 and a kvm instance.

In short - I setup a kvm - but cannot attach via external vnc
what is the easiest how-to for us to follow here -

server id is 101

Strange - seems I can do this on the 1.3 and earlier - but 1.4 just cannot get it to work (go figure)

typo3usa
11-18-2009, 10:17 PM
even trying this

# nc -l -p 5900 -c "qm vncproxy 5900 101 password" fails

:-<

i get connection refused and then that process stops on the server

BitRausch
11-19-2009, 12:11 AM
having issues getting this to work for 1.4 and a kvm instance.

In short - I setup a kvm - but cannot attach via external vnc
what is the easiest how-to for us to follow here -

server id is 101

Strange - seems I can do this on the 1.3 and earlier - but 1.4 just cannot get it to work (go figure)

Hi typo3usa,

I tried it today and it worked very well. I did what clipcarl recommended.
I use UltraVNC as a client to connect to all my KVM instances. Are you sure you opend the ports on the router (if you are behind one)? And forward them to the pve ip - not to the kvm internal nic?

kind regards
BitRausch

BiagioParuolo
11-26-2009, 12:16 PM
I added this to my /etc/inetd.conf so that I can always connect to my VMs with an external viewer:
9001 stream tcp nowait root /usr/sbin/qm qm vncproxy 101 SecretPassword
9002 stream tcp nowait root /usr/sbin/qm qm vncproxy 102 SecretPassword
9003 stream tcp nowait root /usr/sbin/qm qm vncproxy 103 SecretPassword
9004 stream tcp nowait root /usr/sbin/qm qm vncproxy 104 SecretPassword
9005 stream tcp nowait root /usr/sbin/qm qm vncproxy 105 SecretPassword
9006 stream tcp nowait root /usr/sbin/qm qm vncproxy 106 SecretPassword
9007 stream tcp nowait root /usr/sbin/qm qm vncproxy 107 SecretPassword
9008 stream tcp nowait root /usr/sbin/qm qm vncproxy 108 SecretPassword

It goes on 1.4 version...
and you remember to made: sh openbsd-inetd restart

Bye

BiagioParuolo
11-26-2009, 12:17 PM
And How to automate: vncterm --rfbport 5900 -c vzctl enter 777
?

zordio
11-30-2009, 02:31 AM
I've come up with the attached script to spawn (and respawn) VNC listeners for OpenVZ containers. The script assumes each one listens on 59XX (for 100-199 of course). Usage notes are included at the top of the script.

Usage:
Start with: nohup vz_vnclisten <VMID> &
Stop with: kill `cat /var/run/vz_vnclisten_<VMID>` (may take a while to stop)
Start on boot by adding to /etc/rc.local:
/usr/local/sbin/vz_vnclisten <VMID> &

Marcel Gautschi
02-13-2010, 06:51 PM
Hi there,

I read this thread on and on to connect my external vnc to the proxmox kvm sessions with "chicken vnc" on Mac. It didn't go well since now and i tought i share my solution with you guys, who has MacOSX 10.6.2.

On my Site this steps works:

1. Download wine from the internet and install it -> http://winebottler.kronenberg.org/
2. Download also Thight VNC only the excecutable Edition -> http://www.tightvnc.com/download/1.3.10/tightvnc-1.3.10_x86_viewer.zip
3. Start on your Proxmox VNC Server via SSH following command: nc -l -p 5900 -c "qm vncproxy VMID PASSWORD" -> exp.: nc -l -p 5900 -c "qm vncproxy 101 mypassword"
-> tnx for this solution @dietmar
4. Just execute the vncviewer from your Mac -> type in the box your IP ADRESS:PORT -> exp: 192.168.1.1:5900
5. Enter your password

-> Now id should work on your Mac to ;-)

Just to explain why i used TightVnc with Wine?

- I wasn't able to connect over firefox to the openvnc session -> it always gave me a blank page
- I tryed safari too, it works for the moment but it didn't fit the screen size so its not really nice to work with it
- So if i tested the firefox and Internetexplorer from my Bootcamp Partition Windows 7 it always worked perfectly, also tightVnc worked without any problem

helfrez
02-25-2010, 10:50 PM
Does anyone know of a way to obtain some form of logging information using the vncproxy method? I would really like to be able to log connection attempts and subsequently authentication failures. Anyone have any pointers?

Is it possible to specify an interface for the vncproxy? On servers with multiple interfaces, it would be nice to only open the connection on a single interface/address.

itazuramono
03-29-2010, 09:09 PM
I added this to my /etc/inetd.conf so that I can always connect to my VMs with an external viewer:
9001 stream tcp nowait root /usr/sbin/qm qm vncproxy 101 SecretPassword
9002 stream tcp nowait root /usr/sbin/qm qm vncproxy 102 SecretPassword
9003 stream tcp nowait root /usr/sbin/qm qm vncproxy 103 SecretPassword
9004 stream tcp nowait root /usr/sbin/qm qm vncproxy 104 SecretPassword
9005 stream tcp nowait root /usr/sbin/qm qm vncproxy 105 SecretPassword
9006 stream tcp nowait root /usr/sbin/qm qm vncproxy 106 SecretPassword
9007 stream tcp nowait root /usr/sbin/qm qm vncproxy 107 SecretPassword
9008 stream tcp nowait root /usr/sbin/qm qm vncproxy 108 SecretPassword

at my job we are using this setup right now, we have a promox high-availibity cluster (http://en.wikipedia.org/wiki/High-availability_cluster), meaning different ip address, my question is there a way to connect directly to the vm's,

for instance we have several win vm's if in any case one system goes down that means that whoever is connect to that vm will get timed out, because the system that takes over has a different ip address all together, so i guess

my real question is can i use a remote desktop program like krdc to connect to a windows vm using the vm's ip address and port instead of the actual proxmox machine.

tom
03-29-2010, 09:11 PM
windows rdp? why not. just enable on the windows side. no proxmox ve specific settings.

itazuramono
03-29-2010, 09:12 PM
I added this to my /etc/inetd.conf so that I can always connect to my VMs with an external viewer:
9001 stream tcp nowait root /usr/sbin/qm qm vncproxy 101 SecretPassword
9002 stream tcp nowait root /usr/sbin/qm qm vncproxy 102 SecretPassword
9003 stream tcp nowait root /usr/sbin/qm qm vncproxy 103 SecretPassword
9004 stream tcp nowait root /usr/sbin/qm qm vncproxy 104 SecretPassword
9005 stream tcp nowait root /usr/sbin/qm qm vncproxy 105 SecretPassword
9006 stream tcp nowait root /usr/sbin/qm qm vncproxy 106 SecretPassword
9007 stream tcp nowait root /usr/sbin/qm qm vncproxy 107 SecretPassword
9008 stream tcp nowait root /usr/sbin/qm qm vncproxy 108 SecretPassword

at my job we are using this setup right now, we have a promox high-availibity cluster (http://en.wikipedia.org/wiki/High-availability_cluster), meaning different ip address, my question is there a way to connect directly to the vm's,

for instance we have several win vm's if in any case one system goes down that means that whoever is connect to that vm will get timed out, because the system that takes over has a different ip address all together, so i guess

my real question is can i use a remote desktop program like krdc to connect to a windows vm using the vm's ip address and port instead of the actual proxmox machine.

dietmar
03-30-2010, 09:54 AM
my real question is can i use a remote desktop program like krdc to connect to a windows vm using the vm's ip address and port instead of the actual proxmox machine.

Why not?

itazuramono
03-30-2010, 04:39 PM
Why not?

why not with proxmox? well for us it works but trying to find a better way for it to

work because we do not have a heartbeat address, each system in the cluster has a

fixed ip, so when node goes down and there are employees connected to the vm's then

there work would be interrupted. and would have to connect to the vm on the other

system where as if it were connected to the vm directly since our system takeover are

instantaneous, then they would not have any interruption.our vm's have fixed ip leases

from our dhcp servers.

SuperMiguel
03-30-2010, 06:10 PM
Hi there,


- I wasn't able to connect over firefox to the openvnc session -> it always gave me a blank page
- I tryed safari too, it works for the moment but it didn't fit the screen size so its not really nice to work with it
- So if i tested the firefox and Internetexplorer from my Bootcamp Partition Windows 7 it always worked perfectly, also tightVnc worked without any problem


you ever found a fix for this? on how to use firefox? besides using the chicken of vnc

peterx
08-26-2010, 11:07 PM
Thanks Clipcarl.
It works fine.
Just two remarks.
I had to restart openbsd-inetd by proxmox2:~# /etc/init.d/openbsd-inetd restart.
In a cluster you need to change /etc/inetd.conf for the vm in the node where the vm is placed and use the IP of that node!!
As a client I use Remmina on Linux Mint 8. Works like a charm!!

Peter

Erk
08-27-2010, 03:20 AM
you ever found a fix for this? on how to use firefox? besides using the chicken of vnc

For Safari all you need to do is edit /usr/share/pve-manager/root/qemu/vnc-direct.htm and change:

$out .= "<APPLET id=vncapp CODE='VncViewer.class' ARCHIVE='/vncterm/VncViewer.jar' width=640 height=480 vspace=0 hspace=0>\n";

to $out .= "<APPLET id=vncapp CODE='VncViewer.class' ARCHIVE='/vncterm/VncViewer.jar' width=800 height=600 vspace=0 hspace=0>\n";


Then the missing line problem goes away. No idea how to fix the blank white page in Firefox.

jcordonh
01-04-2011, 08:01 PM
hi, i am new in this job, i need to know how to do this permanent.

tks

braykarlos
01-21-2011, 08:35 PM
He usado:

nc -l -p 5901 -c "/usr/sbin/qm vncproxy 101 pass"

y funciona perfecto, pero cuando configuro /etc/inetd.conf con:

5901 stream tcp nowait root /usr/sbin/qm qm vncproxy 101 pass

Reinicio: /etc/initd.openbsd-inetd restart

pero no conecta, el puerto está abierto con inetd:

Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 0.0.0.0:5901 0.0.0.0:* LISTEN 8149/inetd

al conectarme con vncviewer obtengo:
vncviewer 192.168.xxx.xxx:5901
Not a valid VNC server


uso la versión Proxmox VE 1.7


Gracias!!!!!!!!!!!!....

Gleb Legasov
07-01-2011, 04:26 PM
If start a server with

nc -l -p 5900 -c "qm vncproxy VMID PASSWORD"
this server close after quit from External VNC viewer.
But I need that this server work permanent, without closing.
How?

dietmar
07-01-2011, 07:41 PM
this server close after quit from External VNC viewer.
But I need that this server work permanent, without closing.
How?

use inetd

m4z
10-24-2011, 06:58 PM
- I wasn't able to connect over firefox to the openvnc session -> it always gave me a blank page
On Linux workstations, we see similar problems. Here, they occur because we use Client certificates and the Java client has no knowledge of them. If this might be the reason in your case too, you can try:
- make sure your firefox has no expired (client other) certificates
- make sure your java control panel has NO expired (client or other) certificates and ALL your needed, if any, valid client certificates:
1. run ControlPanel, or if it is not in your PATH, something like /usr/lib/jvm/java-VERSION/jre/bin/ControlPanel;
2. go to "security" -> "certificates"
3. choose certificate type "client authentication"
4. under "user", remove expired certificates and import any existing current user certificates.

In any case I would assume it is a problem related to your Java Client and SSL.

Gabe462
09-16-2012, 04:48 AM
nc -l -p 5900 -c "qm vncproxy VMID PASSWORD"



That's not working for me. The vncproxy appears to start listening on 5900 (the port is open) but after I connect the listener stops and I get

400 wrong number of arguments
qm vncproxy <vmid>


What's wrong?

Gabe462
09-16-2012, 08:04 AM
nc -l -p 5900 -c "qm vncproxy VMID PASSWORD"


I get:

400 wrong number of arguments
qm vncproxy <vmid>

What's wrong?

leestukor
09-16-2012, 11:21 AM
I get the error:

400 wrong number of arguments
qm vncproxy <vmid>

I am using Proxmox 2.1 and I VNC Viewer client.

Please help.

Thank you.

dietmar
09-16-2012, 03:50 PM
All our command have a manual page, and can display correct syntax with:

# qm help vncproxy

(hint: you do not need to specify a password).

acjohnson
02-22-2013, 06:15 AM
I'm confused. If you can't specify a password then how does this work now?

I am able to run this command:


nc -l -p 5901 -c "/usr/sbin/qm vncproxy 101"

but every time I attempt to connect with:


vncviewer hostname:5901

I get:


Connected to RFB server, using protocol version 3.8
Server did not offer supported security type

and on the server the connection just closes out without any error message...

How am I supposed to make this work without supplying a password??

tom
02-22-2013, 10:55 AM
do you use 2.x? if yes, you are in the wrong forum/thread.

acjohnson
02-22-2013, 11:33 AM
Yes I am running 2.x and I am having the same problem that leestukor (http://forum.proxmox.com/members/22461-leestukor) is having who also posted on this thread 5 months ago.

Is there another thread that I can post to or do I need to create a new one?

acjohnson
02-23-2013, 06:11 AM
Ahh, I did some more searching and found the answer!

For Proxmox VE 2.0 the answer is on this thread:

http://forum.proxmox.com/threads/10018-VNC-2-0-possible-via-external-VNC-Viewer