PDA

View Full Version : Can't delete/disable LVM Storage



joolsr
06-24-2010, 01:37 PM
Hi I get this error when I try to delete or disable my LVM storage that i created erroneously. Running 1.5

Error: command '/sbin/vgchange -aln pve' failed with exit code 5

Any ideas how i can remove it ?

Julian

tom
06-24-2010, 02:12 PM
remove it manually on all nodes (edit the /etc/pve/storage.cfg file)

joolsr
06-24-2010, 02:24 PM
Ok, that helped

But If I go back add a LVM Group, accept defaults. Then try to disable or delete I get the same error message again

tom
06-24-2010, 02:27 PM
post pveversion -v, you got the latest version?

and give details how to reproduce.

joolsr
06-24-2010, 02:36 PM
Using 1.5 iso with updated new 2.6.32 kernel

Here goes:-

vm:/etc/pve# pveversion -v
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "en_GB.utf8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
pve-manager: 1.5-9 (pve-manager/1.5/4728)
running kernel: 2.6.32-2-pve
proxmox-ve-2.6.32: 1.5-7
pve-kernel-2.6.32-2-pve: 2.6.32-7
pve-kernel-2.6.18-2-pve: 2.6.18-5
qemu-server: 1.1-14
pve-firmware: 1.0-5
libpve-storage-perl: 1.0-13
vncterm: 0.9-2
vzctl: 3.0.23-1pve11
vzdump: 1.2-5
vzprocps: 2.0.11-1dso2
vzquota: 3.0.11-1
pve-qemu-kvm: 0.12.4-1
ksm-control-daemon: 1.0-3

To reproduce, I just do

1 Add LVM Group
2 Give it a name
3 Accept defaults, ie base Storage is Existing Volume Groups (of which i havent set any up), Vol Group Name (pve 690GB), Enable ticked, Shared unticked, Content, Virtual Disks
4 Press Save

Thanks again for your help. It seems perhaps, that local dir is setup with LVM by default, and i dont need to do anything else, - please see linked forum topic here http://forum.proxmox.com/threads/4160-Can-you-use-snapshots-without-using-LVM

Julian

joolsr
06-24-2010, 02:43 PM
If a normal 'Directory' as you call it is really a LVM then it might be better to mention this in the docs/wiki, as it confused me.

dietmar
06-24-2010, 04:16 PM
By default VG 'pve' is used by the system - so you can't remove or deactivate it.

joolsr
06-24-2010, 04:23 PM
Yes, I think I understand now. VG and LVM is setup bry default even for a normal directory. I thought I had to set up LVM via the Add LVM in the gui. Perhpas this could be made a little clearer in the docs ?

Still a great system though !!;-)