PDA

View Full Version : Windwos 2003 KVM does not start after upgrade to new kernel 2.6.32-2-pve



jaco@vpnt.co.za
06-22-2010, 08:18 PM
Hi

Please help

I upgraded the 1.5 see output below:
after reboot I get this error when KVM tries to start

vm-1:/var/lib/vz/images/101# qm start 101
qemu: could not open disk image : No such file or directory
start failed: command '/usr/bin/kvm -monitor unix:/var/run/qemu-server/101.mon,server,nowait -vnc unix:/var/run/qemu-server/101.vnc,password -pidfile /var/run/qemu-server/101.pid -daemonize -usbdevice tablet -name SAP -smp sockets=8,cores=2 -boot menu=on,order=cad -vga cirrus -tdf -localtime -rtc-td-hack -k en-us -drive file=/var/lib/vz/images/101/vm-101-disk-1.qcow2,if=ide,index=0,boot=on -drive file=,if=ide,index=2,media=cdrom -m 18432 -net tap,vlan=0,ifname=vmtab101i0,script=/var/lib/qemu-server/bridge-vlan -net nic,vlan=0,model=virtio,macaddr=92:CF:D0:37:FD:CB' failed with exit code 1

If I check the storage the file is there

vm-1:/var/lib/vz/images/101# ls -l
total 63648972
-rw-r--r-- 1 root root 65112887296 Jun 22 17:14 vm-101-disk-1.qcow2


_________________
output of upgrade
_______________

vm-1:~# apt-get update
Get:1 http://download.proxmox.com lenny Release.gpg [198B]
Get:2 http://download.proxmox.com lenny Release [2458B]
Ign http://download.proxmox.com lenny/pve Packages/DiffIndex
Get:3 http://security.debian.org lenny/updates Release.gpg [835B]
Ign http://download.proxmox.com lenny/pve Packages
Hit http://ftp.debian.org lenny Release.gpg
Get:4 http://download.proxmox.com lenny/pve Packages [8345B]
Get:5 http://security.debian.org lenny/updates Release [40.8kB]
Hit http://ftp.debian.org lenny Release
Ign http://ftp.debian.org lenny/main Packages/DiffIndex
Ign http://ftp.debian.org lenny/contrib Packages/DiffIndex
Hit http://ftp.debian.org lenny/main Packages
Hit http://ftp.debian.org lenny/contrib Packages
Ign http://security.debian.org lenny/updates/main Packages/DiffIndex
Ign http://security.debian.org lenny/updates/contrib Packages/DiffIndex
Get:6 http://security.debian.org lenny/updates/main Packages [308kB]
Hit http://security.debian.org lenny/updates/contrib Packages
Fetched 360kB in 20s (17.7kB/s)
Reading package lists... Done
vm-1:~# aptitude install proxmox-ve-2.6.32
Reading package lists... Done
Building dependency tree
Reading state information... Done
Initializing package states... Done
Writing extended state information... Done
Reading task descriptions... Done
The following NEW packages will be installed:
ksm-control-daemon{a} proxmox-ve-2.6.32 pve-kernel-2.6.32-2-pve{a}
pve-qemu-kvm{a}
The following packages will be REMOVED:
proxmox-ve-2.6.18{a} pve-qemu-kvm-2.6.18{a}
0 packages upgraded, 4 newly installed, 2 to remove and 50 not upgraded.
Need to get 50.6MB of archives. After unpacking 1982kB will be used.
Do you want to continue? [Y/n/?] y
Writing extended state information... Done
Get:1 http://download.proxmox.com lenny/pve ksm-control-daemon 1.0-3 [5474B]
Get:2 http://download.proxmox.com lenny/pve pve-kernel-2.6.32-2-pve 2.6.32-7 [48.8MB]
Get:3 http://download.proxmox.com lenny/pve pve-qemu-kvm 0.12.4-1 [1806kB]
Get:4 http://download.proxmox.com lenny/pve proxmox-ve-2.6.32 1.5-7 [4086B]
Fetched 50.6MB in 53min33s (15.7kB/s)
(Reading database ... 24654 files and directories currently installed.)
Removing proxmox-ve-2.6.18 ...
dpkg: pve-qemu-kvm-2.6.18: dependency problems, but removing anyway as you request:
qemu-server depends on pve-qemu-kvm (>= 0.11.1) | pve-qemu-kvm-2.6.18; however:
Package pve-qemu-kvm is not installed.
Package pve-qemu-kvm-2.6.18 is to be removed.
Removing pve-qemu-kvm-2.6.18 ...
Processing triggers for man-db ...
Selecting previously deselected package ksm-control-daemon.
(Reading database ... 24594 files and directories currently installed.)
Unpacking ksm-control-daemon (from .../ksm-control-daemon_1.0-3_all.deb) ...
Selecting previously deselected package pve-kernel-2.6.32-2-pve.
Unpacking pve-kernel-2.6.32-2-pve (from .../pve-kernel-2.6.32-2-pve_2.6.32-7_amd64.deb) ...
Selecting previously deselected package pve-qemu-kvm.
Unpacking pve-qemu-kvm (from .../pve-qemu-kvm_0.12.4-1_amd64.deb) ...
Selecting previously deselected package proxmox-ve-2.6.32.
Unpacking proxmox-ve-2.6.32 (from .../proxmox-ve-2.6.32_1.5-7_all.deb) ...
Processing triggers for man-db ...
Setting up ksm-control-daemon (1.0-3) ...
Setting up pve-kernel-2.6.32-2-pve (2.6.32-7) ...
update-initramfs: Generating /boot/initrd.img-2.6.32-2-pve
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
Searching for splash image ... none found, skipping ...
Found kernel: /vmlinuz-2.6.32-2-pve
Found kernel: /vmlinuz-2.6.18-2-pve
Found kernel: /memtest86+.bin
Updating /boot/grub/menu.lst ... done

Setting up pve-qemu-kvm (0.12.4-1) ...
Setting up proxmox-ve-2.6.32 (1.5-7) ...
installing proxmox release key: OK
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done
Reading task descriptions... Done

uname -a
Linux vm-1 2.6.32-2-pve #1 SMP Thu Apr 15 10:22:46 CEST 2010 x86_64 GNU/Linux


pveversion -v

pve-manager: 1.5-9 (pve-manager/1.5/4728)
running kernel: 2.6.32-2-pve
proxmox-ve-2.6.32: 1.5-7
pve-kernel-2.6.32-2-pve: 2.6.32-7
pve-kernel-2.6.18-2-pve: 2.6.18-5
qemu-server: 1.1-11
pve-firmware: 1.0-3
libpve-storage-perl: 1.0-8
vncterm: 0.9-2
vzctl: 3.0.23-1pve8
vzdump: 1.2-5
vzprocps: 2.0.11-1dso2
vzquota: 3.0.11-1
pve-qemu-kvm: 0.12.4-1
ksm-control-daemon: 1.0-3


Many Thanks
Jaco

jaco@vpnt.co.za
06-22-2010, 08:38 PM
What I notice before the upgrade

vm-1:~# df -h
Filesystem Size Used Avail Use% Mounted on
/dev/pve/root 67G 21G 43G 33% /
tmpfs 12G 0 12G 0% /lib/init/rw
udev 10M 2.9M 7.2M 29% /dev
tmpfs 12G 4.0K 12G 1% /dev/shm
/dev/mapper/pve-data 174G 90G 85G 52% /var/lib/vz/dev/sda1 504M 32M 448M 7% /boot

and after the upgrade

vm-1:/etc# df -h
Filesystem Size Used Avail Use% Mounted on
/dev/mapper/pve-root 67G 21G 43G 34% /
tmpfs 12G 0 12G 0% /lib/init/rw
udev 10M 748K 9.3M 8% /dev
tmpfs 12G 4.0K 12G 1% /dev/shm
/dev/mapper/pve-data 174G 90G 85G 52% /var/lib/vz
/dev/sda1 504M 46M 433M 10% /boot

contents of fstab

vm-1:/etc# cat /etc/fstab
# <file system> <mount point> <type> <options> <dump> <pass>
/dev/pve/root / ext3 errors=remount-ro 0 1
/dev/pve/data /var/lib/vz ext3 defaults 0 1
UUID=801e18e5-4a4d-4b23-976d-e05daa3d4076 /boot ext3 defaults 0 1
/dev/pve/swap none swap sw 0 0
proc /proc proc defaults 0 0

udo
06-22-2010, 11:17 PM
...
vm-1:/var/lib/vz/images/101# qm start 101
qemu: could not open disk image : No such file or directory
start failed: command '/usr/bin/kvm -monitor unix:/var/run/qemu-server/101.mon,server,nowait -vnc unix:/var/run/qemu-server/101.vnc,password -pidfile /var/run/qemu-server/101.pid -daemonize -usbdevice tablet -name SAP -smp sockets=8,cores=2 -boot menu=on,order=cad -vga cirrus -tdf -localtime -rtc-td-hack -k en-us -drive file=/var/lib/vz/images/101/vm-101-disk-1.qcow2,if=ide,index=0,boot=on -drive file=,if=ide,index=2,media=cdrom -m 18432 -net tap,vlan=0,ifname=vmtab101i0,script=/var/lib/qemu-server/bridge-vlan -net nic,vlan=0,model=virtio,macaddr=92:CF:D0:37:FD:CB' failed with exit code 1

...
Hi,
i think not the vm-101-disk-1.qcow2 is the problem but perhaps the empty cdrom:


file=,if=ide,index=2,media=cdrom

Can you remove the cdrom from the gui?

Perhaps it's help

Udo

jaco@vpnt.co.za
06-23-2010, 06:55 AM
I deleted the CDROM from the gui

and it started,

Many thanks UDO