PDA

View Full Version : Tales for hell… how to migrate from ESXi to Proxmox the first time



alevene
05-16-2010, 04:16 AM
We use a Dell server running ESX1 v4 and two OS – a 500GB Windows 2003 and a smaller SuSe Linux 11.1 server.



Round One


My first test was to restore a backup of the Windows server to the new Proxmox server. I had created a 500GB virtual Windows environment in the ESXi. Using the web Proxmox interface I created a 500 GB .raw file for the Windows server. Proxmox will create 3 different formats, .raw (I think the most efficient), .qcow2 (something to do with milk production :p ) and .vmdk, the native ESXi format. I inserted the Storage Tech recovery CD into the Proxmox drive, started the new Windows server and booted into the Storage Craft CD which “restored” the Windows Server from the backup into the .raw file once I found it across the network.



I thought about, but did not try to use the eSATA drive with the external backup attached to the Proxmox server as this was another layer of complexity I didn’t want to try at this time. Perhaps someone else will write about mounting a VMware .vmdk volume as an external drive under Proxmox.


Anyway, the restore worked without problem; the server came to life immediately and within 30 minutes I had removed the VMware tools, reregistered the Windows server with Microsoft and I was satisfied it was in production mode with the same IP as the original. Note, be sure to shut down or unplug the network cable from the VMware box as the virtual systems come to life with the same IPs.



I should also note that the original server used an Intel chip, the Proxmox, an AMD. I’m not sure if it would have worked the other way around so that the Windows server would have so easily come to life if its drivers would have been AMD oriented, but someone else can comment.


Round Two


My second test was to copy the two SuSe .vmdk files to the Linux volume I had already setup – folder 102. The big problem I had was in finding a copy utility that would complete the job without timing out. I found that WinSCP was useless, but FastSCP and VMX worked well, but not well enough. I’ll explain.



The first job was enable SSH on the ESXi server, by editing the /etc/inetd.conf which requires logging into the ESXi console, removing one # character, saving the inetd.conf file and rebooting the system. The web has many locations describing how to do this. Once done you can log in as root remotely via any of these utilities.


I navigated to the ESXi volumes where the two Suse .vmdk files lived and copied them to my Proxmox image folder that I had created as a Linux server, 102 in my instance. According to what I read (which appeared to be wrong) I had to convert the smaller file to QEMU2 format which I did on my local PC using VMware utilities and, after a lot more effort, copied the new qcow file to the 102 folder so I had 3 files in it, 2 .vmdk and one .qcow. I accessed the Proxmox interface, and started the system. Nothing! After posting on the forum, and thanks to some very bright people I realized that I had missed a BIG step… I had not registered the new files to the Proxmox system which I did in ten seconds.


Further, after a lot more research I found that I didn’t need to covert the .vmdk files after all, just add them as native .vmdk’s to the folder, register them as hard disks and the SuSe system came to life without its graphical interface. Running sax2 fixed that in a minute. Then removing VMware tools gave me a system using the same IP as the original.


Round Three


This was my most difficult part of the project… actually copying the 500GB .vmdk file from the ESXi folder to the Proxmox, 101 folder. No matter which graphical tool, from whatever Windows or Linux machine on the network, that I used even scp from a terminal windows, they would always time out and I never got a good copy.



My only solution was to use the scp (secure copy) from the Proxmox console and pull the file that way. I think the command was -
scp root@192.168.1.3:/vmfs/volumes/NetCon/SBS2003/SBS2003-flat.vmdk /var/lib/vz/images/101


Note the only spaces, one after scp and the other, after .vmdk. When complete, 12 hours in my instance. I started the Windows system in the 101 folder with just the two .vmdk files in it and it came to life… see round one.


One final note. I’d suggest using 10/100/1000 Gigabit cards in both machines, perhaps with a long crossover cable or a small 10/100/1000 Gigabit switch in the middle, for the transfer of the big file. It would have made the experiments much quicker, from 12 to probably 3 hours for me as I only had a 100Mbps switch in the middle chugging along at 10.4 MBps.


Good luck with your projects, and be sure to post your insights to help everyone else in the community.